?
Solved

Windows 7 machine won't access network devices

Posted on 2012-08-18
48
Medium Priority
?
948 Views
Last Modified: 2012-09-11
I have a Windows 7 Home Premium machine.  I'm unable to access a NAS via its UNC or IP.  I can view the NAS via its webportal.  I can access the NAS either way via another computer.  I have removed the Norton software completely and disabled the Windows firewall during my troubleshooting.  

I have set the network to home.  I am connected to a printer via IP also.
0
Comment
Question by:1namyln
  • 26
  • 10
  • 4
  • +4
45 Comments
 
LVL 71

Accepted Solution

by:
Qlemo earned 1000 total points
ID: 38308153
"Disabled Windows firewall" does not mean that you stopped the service?
Make sure the Norton software is really uninstalled - some products do not perform a clean deinstallation, leaving some system DLLs injected for example, and leading to unpredictable system behaviour.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38308158
The service was running.  I stopped it.  I used the Norton removal tool.  I restarted.  I checked the services to see if there were any lingering Norton instances.  I found none.

After stopping the firewall service the problem still exists.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 38308166
Sorry, I didn't mean to tell you to stop the Windows Firewall service - that can have unpredictable results for network operations. So please start it again, but keep it disabled (for the moment).

Try if the following gives you a result:
   telnet YourNASIP 139
You should get a console where you can type in (nothing returned). Stop the connection by pressing Ctrl+Plus, and typing quit.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:1namyln
ID: 38308167
I'm unable to connect using \\mycomputername or \\127.0.0.1.
0
 
LVL 8

Expert Comment

by:databoks
ID: 38308179
If you can access the web portal I might think it could be a permission problem.

Make sure the permission is set. For testing purposes add "everyone" to the acess list.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38308197
Permissions error on the NAS?  I can access it from other computers with no issue.  XP and Windows 7.  If you're referring to the users and groups in the Buffalo software I can't add everyone without a password.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38308216
I can ping the name of the device and its ip.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 38308271
What about http:#a38308166 ?
0
 
LVL 1

Author Comment

by:1namyln
ID: 38308273
The link posted is a link to this page.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38308335
When I type telnet ip 139 into a command prompt another black window pops up with telnet myip at the top but it just stays there.  Nothing happens.  The windows stays black and displays no further text.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 38308501
That is to be expected. If you type in that window, nothing happens (in particular the window does not close)? If the window does not close, either kill it or press Ctrl+Plus, then type quit (as described in my prior comment).

The window remaining open means that the connection to the NAS works on the old SMB port (139/tcp). Then I'm supposing the W7 machine tries with CIFS (445/tcp), and does not fall back to the "conventional" SMB protocol ports ...
0
 
LVL 1

Author Comment

by:1namyln
ID: 38309564
Still no resolve.  I needed this functionality so I could backup to the NAS.  The backup program can also backup via FTP.  I enabled this on my NAS and I'm able to work around it for now.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38309721
Sweet!  Thx. I don't feel neglected. I always feel like I get my $13 bucks worth. :)
0
 
LVL 44

Assisted Solution

by:Davis McCarn
Davis McCarn earned 1000 total points
ID: 38309724
I hate to interject; but, hey experts (!), read the question AND know his O/S.
Your issue is that Windows 7 set to a "Home" network automatically creates a "Homegroup" that only supports other Windows 7 computers.  ( I NEVER choose "Home" for the network location in 7 because of that ).  Go to the Network and Sharing Center, double click on the Home link, and change the network type to Work.
Once you have changed that, double click the link under the center icon to have Windoze search the network and I'll bet the NAS appears.
Then, go get Microsoft Security Essentials ( http://windows.microsoft.com/en-US/windows/products/security-essentials ) to replace Norton.  Its better and its free.
0
 
LVL 10

Expert Comment

by:Gajendra Rathod
ID: 38309926
Please check on Windows 7 Home Premium machine

Control Panel |Credential Manager

Remove any stored credential for that NAS.

Create one new user that has same username and password as other windows 7 machine on which you are able to access the NAS.
0
 
LVL 18

Expert Comment

by:web_tracker
ID: 38309930
I would upgrade to windows 7 pro instead of home it has better networking capabilities.
0
 
LVL 52

Expert Comment

by:Jackie Man
ID: 38310447
If your system is Windows 7 Home Premium, you may change it from Registry.

1. Launch regedit from Start Search box.
2. Find the following branch.
 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

3. Create a DWORD key under Lsa and set:

Name: LmCompatibilityLevel
Value: 1

4. Restart."

Source: http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/91fe4e10-a0d4-45db-94df-fad885d8f64f

If your system is Windows 7 Professional, try the following:-

1. Run secpol.msc and a window called "Local Security Policy" will be open;

2. Goto Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level

3. Change the default value of "LAN Manager authentication level" to "Send LM & NTLM - use NTLMv2 session security if negotiated:"

4. Restart
0
 
LVL 1

Author Comment

by:1namyln
ID: 38312323
Jackieman, I'll try this and repost.  Should be late this evening.  Thanks.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38312569
Please read my post.  I guarantee it is your problem! http:#a38309724
0
 
LVL 1

Author Comment

by:1namyln
ID: 38312582
Davis,  I did everything except remove the Norton.  This customer wants to maintain their Norton.  I agree its crap but...
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38312673
In Norton, then, you need to create a trusted network.  How you do it depends on the version.  Which version of Norton?
0
 
LVL 1

Author Comment

by:1namyln
ID: 38312729
Internet Security, the latest version.  Earlier in my post though I mentioned removing Norton completely, using the removal tool, and still couldn't access via unc or IP.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38313113
But the network location is now "Work"?
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38313723
As long as the network type or location is Home, Windows will outsmart you.  You must change it to a Work network.
Norton's network "trust" settings will also put the kabosh on viewing network devices (other than printers or routers) so you'll need to set that, too: https://www-secure.symantec.com/norton-support/jsp/help-solutions.jsp?ct=us&lg=en&product=home&pvid=f-home&version=1&docid=v15978324_NIS_Retail_2012_en_us
0
 
LVL 1

Author Comment

by:1namyln
ID: 38336546
Jackieman, tried the registry changes, no change.  Davis, verified Work network and added network to trusted within Norton.  No change.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38337998
So when you open the network and sharing center, double-click the center icon at the top, and let Windoze scan the network, nothing appears?
Are there other PC's on the network?
0
 
LVL 1

Author Comment

by:1namyln
ID: 38338569
I can see one pc. If I click start the type \\unc or \\ip for the computer that I can see when I click the network I get the same error as if j types the nas or other devices.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38338884
The nas and the computer in question are I'm the same workgroup.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38339202
As a reminder I can't access the PC using \\myunc or \\127.0.0.1.  However a ping to either replies successful.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38339261
I'm unable to share on this system.  When I attempt to share I get the same type error.  This action can't be completed on this system.  I have created another user with admin permissions to see if its specific to the user but I have the same problems.
0
 
LVL 52

Expert Comment

by:Jackie Man
ID: 38339263
"Earlier in my post though I mentioned removing Norton completely, using the removal tool" -> Have you reestarted the computer before you tried to access the NAS?
0
 
LVL 1

Author Comment

by:1namyln
ID: 38339275
Yes.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38340789
Was there another antivirus product in the past?
CA, Trend Micro, and McAfee all love to only partially uninstall and leave network sentry drivers behind.
To check, do Start, and in the search box type CMD <CTRL-SHIFT-ENTER> to open an elevated CMD window.  In it, type:
set DEVMGR_SHOW_NONPRESENT_DEVICES=1
devmgmt.msc
Then, in the Device Manager, click View -> Show hidden devices.
What you will have is a device manager which shows every device Windows ever detected rather than one which shows what is there now.
Check the non-plug-and-play section for MFE, NAI, SYM, T?, and VET entries.  If they are all grayed out, yeah (!); but, if any are not, run their removal tool.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38344024
None of the above non-plug-and-play are present.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38345228
OK; whatever is preventing you from sharing is the source of the problem and there ought to be events listed regarding it. It is probably a service which is failing to start.
You can either right-click on Computer and choose Manage, or type EVENTVWR.MSC<enter> in the search box.  Look in the System section of Windows Logs for red-x's and the Security section for Audit Failures.
Because Vista and 7's logs get so huge, I often right-click on the logs folder and clear it (not worth saving either), then attempt the failing action which, in your case, would best be done by going to the advanced sharing options and trying to share the Public folders (its a checkbox).  Afterwards, check the event logs again.
What errors are there?
0
 
LVL 1

Author Comment

by:1namyln
ID: 38345409
I will check this and re-post.  I can only do so in the evening on this machine.  Thanks for the help.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38348364
Checked the logs and cleared.  All security audits state successful.  One error in system to speak of.  Its below.  

TCP/IP has chosen to restrict the scale factor due to a network condition. This could be related to a problem in a network device and will cause degraded throughput.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38351271
Did you try to share the public folders?
That will generate the error we need to address.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38361944
Been away. I will check this tonight and post results. If I can't get it resolved I'm going to reload.  Not sure what other issues I might be inheriting.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38362281
Public sharing works well.  I can share a folder on the desktop and edit it from other computers.  I'm not able to access the computer in questions public folders from the same computer though.  If I double click it I'm told I don't have the appropriate permissions.  If I browse to the local folder I can do what I want.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 38363329
Try this to fix the TCP scaling problem: http://support.microsoft.com/kb/934430
0
 
LVL 1

Author Comment

by:1namyln
ID: 38370378
Reloaded the system.  Thanks for your efforts.
0
 
LVL 1

Author Comment

by:1namyln
ID: 38379402
I've requested that this question be closed as follows:

Accepted answer: 0 points for 1namyln's comment #a38370378
Assisted answer: 250 points for Qlemo's comment #a38308166
Assisted answer: 250 points for DavisMcCarn's comment #a38309724

for the following reason:

Points are for efforts. &nbsp;Thank you!
0
 
LVL 1

Author Comment

by:1namyln
ID: 38379403
I did not mean to accept my own comment.  Can we disregard this and award to the others?  Thanks.
0
 
LVL 1

Author Closing Comment

by:1namyln
ID: 38387358
Thanks for your efforts.  Had to reload the machine.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tech spooks aren't just for those who are tech savvy, it also happens to those of us running a business. Check out the top tech spooks for business owners.
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question