Why cannot i change RDP port from 3389 to 33891 ?

Why cannot i change RDP port from 3389 to 33891 ?
At the same LAN, i can RDP log onto the PC with by default port3389. After i change the port number from 3389 to 33891 in registry,
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp

i found it cannot take effect. 3389 is still work, and 33891 do not work. Anyone can do me favor ? Thank you
davidy2001Asked:
Who is Participating?
 
Dave BaldwinFixer of ProblemsCommented:
Did you reboot the server to make the changes effective?
0
 
mrwad99Commented:
When you change the port number, are you sure you are entering 33891 with "Decimal" selected in registry editor?  Otherwise, 33891 in hex would be 211089 in decimal which is an invalid port number.
0
 
davidy2001Author Commented:
Thank you for your reply. Yes, it is 33891 in decimal (8463 in hex)
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
mrwad99Commented:
OK, so you have made that change on the machine you are trying to connect to.  When you then go onto the client machine and enter the target machine's IP, followed by a colon, then 33891 (eg 10.10.10.10:33891) does the client machine complain that the target machine is not listening on port 33891?  What exactly happens?

Also, what OS are you running?
0
 
davidy2001Author Commented:
I made the change on Win 2008 server, and try to log onto the server from client PC (Win 7).
When i typed the server info 10.10.10.10:33891 in remote desktop connection, it show "Remote Desktop can't connect to the remote computer for one of these reasons: 1) Remote access to the server is not enable. 2) the remote computer is turn off 3) .............." but i can still log onto the server through 3389, not 33891
0
 
davidy2001Author Commented:
i got it after i restarted it. i am thinking if it is in real production, it cannot allowed to restart it.
0
 
davidy2001Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for davidy2001's comment #a38308410
Assisted answer: 500 points for mrwad99's comment #a38308357

for the following reason:

i got it after i restarted it. i am thinking if it is in real production, it cannot allowed to restart it.
0
 
ReneGeCommented:
Hi davidy2001,

Please understand this. If you like to receive help here from experts that are not paid to freely help, the least you can do, is give some happy points.

Having sed that, mrwad99 provided you with the valuable informations so you can figure it out.  If you feel that is true, not only give him all the points, but all the credits by accepting his comment as the solution.

Now, adding to your comment:
i got it after i restarted it. i am thinking if it is in real production, it cannot allowed to restart it.

Yes, you have to restart the service so that the change of RDP port takes effect.  Some times, we must accept what we can't change some stuff by our selves, unless Bill is our best friend.

By the way, DaveBaldwin also provided you with a working solution.

Cheers,
Rene
0
 
davidy2001Author Commented:
Hi Rene

Thank you for your message. As you know, i am new to the forum. Sometime i just did not pay attention to these thing you mentioned, which is important. But I always hope our forum(EE) become better and better. If you have any suggestions, please let me know it. As long as it is good for our forum, I do it.

David
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.