unable to debug a VS2012 project

I've installed the new release of VS2012 on a new Windows 8 machine.

For some reason I'm unable to debug my project. I don't problem building a release, but every time I try to debug, I get the following messages.

I have no problem debugging THE SAME project with VS2010 !!

First error
second error
or1969Asked:
Who is Participating?
 
or1969Author Commented:
after running many tests, the problem (in my case) was the antivirus on my machine (Bitdefender). Removing it solved the problem.

During writing this post, Bitdefender solved the issue.
0
 
AndyAinscowFreelance programmer / ConsultantCommented:
>>I have no problem debugging THE SAME project with VS2010 !!

From the Windows 8 machine ?  (In other words you have both VS2010 and VS2012 installed).  If it is from a different machine it could be a firewall problem.
0
 
or1969Author Commented:
sorry. I wasn't clearer enough.

Machine I with VS2010 and VS2012
Machine 2 with VS2012

On both machine I get the same debug problem.
Disabling the FW didn't solve the problem.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
AndyAinscowFreelance programmer / ConsultantCommented:
So #1 can perform a remote debug with VS2010 but not with VS2012 and #2 can't do a remote debug either.
0
 
Obadiah ChristopherCommented:
I'm not aware of WIndows 8. But does your situation have anything to do with the Run As Admnistrator mode.
0
 
or1969Author Commented:
I'm running with the administrator account
0
 
or1969Author Commented:
also, double-click the .sln project file will start VS2012 and I get the same error (First Error) following with this message

msg3
0
 
AndyAinscowFreelance programmer / ConsultantCommented:
I'm still not clear of your situation.
Are you trying to perform a remote debug of your app running on another PC ?
0
 
Obadiah ChristopherCommented:
Yes. I guess for Wiindows Vista and above. You have to Right Click and select Run as Administrator even if you are logged in using Administrator account.
0
 
or1969Author Commented:
I have no idea what is the connection between the remote debugger and my application as it is a local winform solution with no connection to any remote machines.

and, I tried starting with the 'run as administrator' but it didn't solve the problem.
0
 
Obadiah ChristopherCommented:
Start Visual Studio by typing

devenv /resetskippkgs
0
 
or1969Author Commented:
thanks but this option didn't solve the problem
0
 
or1969Author Commented:
I think I found the solution.
My project is set to build using 'Any CPU'. Changing to x86 solved the problem.

Now I'm having a new problem, how can I keep using the 'Any CPU' option without this problem?
0
 
or1969Author Commented:
found the solution
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.