No audio in one way with sip

Hi, I have installed an asterisk pbx in our company, and now I have installed the ZOIPER in my android phone.
I have a Sonicwall Firewall NSA240, I have created the nat policies to allow the access from outside to the pbx. In the Firewall I have 2 connections - VSAT and Wimax. The Vsat only works for the link to join our main office in another country trough PBX and the wimax is the access to internet, email and now the PBX to the android phones of the workers.
In my first testings I am having problems where I can connect the SIP link, but when making calls I get no audio and the person on the other side cant ear me.
Any ideas?
britholAsked:
Who is Participating?
 
Frosty555Connect With a Mentor Commented:
If you've confirmed that the Zoiper android app works fine on the LAN, then you've got a NAT problem of some kind. This often is a configuration issue on either the extension or Zoiper's end.

You need to forward both TCP and UDP 5060/5061, and UDP 10000-20000. I usually just forward TCP and UDP for everything to keep things simple. I'm assuming you've done that but please doublecheck.

In Asterisk, there's several NAT-related settings that MUST be configured properly for it to work. In particular:

- The deny/permit field of the extension must allow connections from remote networks (and not explicitly limit to the local network)
- The extension's "nat" option must be configured corrected so that SIP header rewriting is correctly done
- Asterisk's sip_nat.conf's config file must define the correct "public IP" and "private IP" that should be used (the WAN and LAN address of the server)

Look at these guides (for FreePBX but it goes for all asterisk installations)

http://www.freepbx.org/support/documentation/howtos/howto-resolving-audio-problems
http://www.freepbx.org/support/documentation/howtos/howto-setup-a-remote-sip-extension
(another one: http://blog.iwayvietnam.com/tuanta/2010/03/10/howto-setup-asteriskfreepbx-behind-nat/)

Similar configurations may need to be done in Zoiper, check if there's a "NAT" option in the configuration screens anywhere, you may need to explicitly specify that you're going through a NAT.

Then there's some extra router settings to consider:

- Neither router should ever use "SIP ALG". If your router has such a feature, make sure it is disabled.

Read this resource:
http://www.voip-info.org/wiki/view/Routers+SIP+ALG
0
 
Frosty555Commented:
This is usually a firewall or port forwarding problem regarding the RTP ports. You forwarded TCP 5060 for the SIP protocol, but what about the range of UDP ports that asterisk is using for RTP? The ports used vary depending on installation but it can be for example, UDP 10000-20000. Look at rtp.conf.

Your router/firewall must forward the ports accordingly and allow them through, and whatever network your cell phone is on must also allow it through. Some cellular providers are known to intentionally cripple 3G data on high UDP ports, either by blocking it completely, or just crippling the flow of data sufficiently to make good quiality VoIP calls impossible, so test it first on a Wifi network that you can control.
0
 
britholAuthor Commented:
Hi, I have forward the ports 5060-5061 in UDP to the pbx, and the RTP are also forward for the 10000-20000 to the pbx. In our network it work fine because the pbx is on the same LAN, but in my home that I have an Wifi it dont work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.