• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 839
  • Last Modified:

Users unable to Save or Save-As on Network Shares - random issue- Storage Server 2008 R2 SP1

Dear Experts,

Our 2003 R2 server crashed and we transferred all of the Shares onto the new HP StorageWorks X1600 G2 NAS with Stoarge Server 2008 R2 SP1 OS.
Domain functional level is currently 2003, will be upgrading to 2008 soon.
Our shares were recreated on the D: Partition of the NAS and users connect to these shares through mapped network drives \\NAS\Share
What started happening immediately since the migration is that User couldn't save any files on the network drives. We corrected the issue by checking the "Delete" check-box under NTFS permissions. That corrected the issue or so we thought....
Now, a slightly different issue is happening randomly where users can not Save or Save-As the files on the network drives. As I mentioned the issue is very random, happens to one person today and to another person tomorrow. I`ve advised my users to try Save-As, that doesn't always work. So now when issue is encountered, users save file to the desktop then copy/paste to the network drive. I`ve also noticed that sometimes when users attempt to save a file, a temp file is generated and an additional empty 0Kb office doc is created. This is not only happening to Office applications, also happens with Adobe InDesign, Photoshop etc.
I thought that it could be Symantec AV related issue, so we installed SEP client on the NAS, we also adjusted the policy to trust other machines that run Antivirus. Disabled scan of network drives but to no avail...
We then rebuilt the share permissions.


Properties of the Share --> Sharing tab --> Advanced Sharing --> Permissions:
Security Group - Change & Read
Domain Admins & Local Administrator - Full Control

Properties of the Share --> Security Tab
System, Local Admin, Domain Admins - Full Control
Security Group - Modify, Read, Write, R&E, List Folders

Properties of the Share --> Security Tab --> Advanced Tab --> selected Security Group --> Change Permissions --> Selected Security Group --> Edit
Everything is checked except for: Full Control,  Change Permissions & Take Ownership

Owner on the Share is Local Administrator

Another thing that I`ve noticed is that when the user creates a new file, that user is automatically set as the Creator Owner. I don't remember if this was also the behavior on the 2003 boxes...

We contacted Microsoft, they bored us with running the net mon captures for almost two weeks and without any results. So one day we run the capture on the client and the NAS and MS can't find anything wrong and have been asking me to rerun the captures.
We also disabled the Offline Caching on the couple of client machines, but it didn't help.
At this point I'm at a loss as Microsoft's latest suggestion was to go inside the NTFS permissions and set the Security Group with permissions to change permissions....
I don't want my users to change permissions period..
Any suggestions ? Forgot to mention, majority of client machiens are WIN7 Pro. We have a few XP boxes, but XP users didn't report this issue.
0
zanderkid
Asked:
zanderkid
  • 4
  • 2
3 Solutions
 
zanderkidAuthor Commented:
i should also add that when this issue occurs, user has to End Task the process as it just gets stuck on Saving. If user attempts to restart the PC, it will stay on "Logging Off" forever without ever restarting. Users then forced to force shut down the PC.
0
 
R3C0NCommented:
After your applying permissions in the sharing tab dialog boxes are you highlighting the security groups and clicking apply. And have you installed the file server role in Server Mannager here's a link

 http://technet.microsoft.com/en-us/library/cc771092(v=ws.10).aspx

-R3c0n
0
 
zanderkidAuthor Commented:
Hello R3c0n,

the answer to both is Yes.
I beleive Storage Sever 2008 R2 - HP x1600 G2 actually comes witf the file server role already installed. Don't remember if I had to installl it manually or not, but it is installed.
I did hit apply every time though.
My next step would be to rename existing share and move data to a newly created share as well as turning off indexing.
I did miss that I also disabled opportunistic locking on the server since PCs would lockup on shutdown or restart. Now disabling the "short file name creation"
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
zanderkidAuthor Commented:
Also, NFS service is disabled. One of the HP guys suggested disabling the SMB 2.0, although I'm not sure this will help since all affected clients run WIN7....
0
 
hecgomrecCommented:
On the the server with the folder/unit/volumen you need to share you should have


Properties of the Share --> Sharing tab --> Permissions:
Everyone Group - Change & Read
"Domain Users" - Change & Read

Properties of the Share --> Security Tab
Users Group - Modify, R&E, List Folders, Read, Write (your selected Group)

Allow inheritable permissions were needed and remove were not needed.

Also in the advanced tab, go to effective permissions and select one of the users with the problem and check efective rights for a specific file or folder inside the share.  Remember rights can conflict with user's rights on another group.  Sometimes you need to do a spot check to see if everything is working as desired.

Hope this help, please let me know
0
 
R3C0NCommented:
Zanderkid,

I know you were clicking apply what I was emphasizing is highlighting any and all newly added Security Groups in the dialog boxes then clicking apply. Do you see the dialog box coming up that shows the files looking like they are copying. Or prompts you if your sure you want to break inheritance. If you highlight the groups in the box I always saw the additional prompts.  And was curious as to your reports your generating from file sever resource manager you should be track changes easily as your trying to move forward. I always created an Security Group All Read and then nested my read and rw security groups within. Create the new folder and remove everything but system and administrator add the SG All read group highlight that and system and administrator and click apply after create a on your subfolders in the parent you can start to apply your rw groups per folder and it will come together. It just sounds like a few too many moving parts for something that I'm sure you've done before. As a suggestion this could become troublesome later without knowing the root of the cause now hence the reason for suggesting just trying a basic scenario.
0
 
zanderkidAuthor Commented:
Hey guys,

I apologize for delayed response. Issue was actually not related to the Permissions. It came down to Disabling all netflow on the offending machines within the NIC properties as well as running the following:
 NETSH INT TCP SET GLOBAL CHIMNEY=DISABLED
NETSH INT TCP SET GLOBAL RSS=DISABLED
NETSH INT TCP SET GLOBAL AUTOTUNING=DISABLED
NETSH INT TCP SET GLOBAL NETDMA=DISABLED

After following the above, the issue appears to have disappeared.
Thank you again for all of your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now