move mailbox error from exch 2003 to exch 2010.

when i am migrating AD and Exchange everything went smooth.

but now when i am moving mailbox i am getting error something like

replication service server not available...

but i checked CAS server replication service is running....

i checked permissions also...How can i fix this error.

please guide me.
nivasnetAsked:
Who is Participating?
 
Manpreet SIngh KhatraConnect With a Mentor Solutions Architect, Project LeadCommented:
Absolutely and also make sure the CAS is able to speak o Mailbox and GC :)

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Check the Replication Service on Mailbox server.

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you please share the screenshot of the error or some details of the error from App logs.

- Rancy
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
nivasnetAuthor Commented:
Please find attached jpg for error code.
exchange-2010-move-request-mrs-e.jpg
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Hope Mailbox role is installed and Microsoft Services are running on it :)
As its E2k10 do you have DAG ?

- Rancy
0
 
nivasnetAuthor Commented:
yes mailbox role is installed, and microsoft services r runing..... we don't have DAG
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
The error is for Microsoft Exchange Replication service .... if its running can you try Restarting and check .... maybe its hung and not responding to the request.

- Rancy
0
 
nivasnetAuthor Commented:
we did several times....no luck
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
How many servers do you have and was any changes made ?
Server version with SP and RU ?
How many mailbox Database do we have ?
Was the move mailbox working fine earlier or just the first instance ?
Hope your account has Full rights to be able to move mailbox ?

Did you try running the below command fix any possible permission issue ?
Setup.com /pad

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Check for any eventID with source "MSExchange Mailbox Replication" or "MSExchange IS" ?

- Rancy
0
 
nivasnetAuthor Commented:
before migrating exchange we migrated AD to new 2008 r2 server. for we run all preparations commands.. in 2003 domain. and 2008 promoted as DC, we transfered all roles to new domain that is 2008. but we didn't retire 2003 domain so far. it also acting as GCS.

is there any problem with 2 GCS servers in single domain.

after migrating exchange successfully we want to retire 2003 dc.

is there any problems keeping 2003 dc in domain as GCS. and not retiring.

please advice.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Hope you also ran the /PrepareLegacy command ?

- Rancy
0
 
nivasnetAuthor Commented:
yes we ran all prepare commands...
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
is there any problem with 2 GCS servers in single domain. - No

Not sure if the W2k8 server is a GC as well .... if so you can demote the W2k3 server from GC to DC and the demote it with dcpromo and make it a member server.

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you re-run the preparead command and restart the ADtopology service ?
Also how many E2k10 servers do we have and roles ?

- Rancy
0
 
nivasnetAuthor Commented:
can i also do like this...

i want revert back all roles to 2003 dc... than is there any problem with Exchange
0
 
nivasnetAuthor Commented:
we have one physical server loaded for mailbox, and hubtransport.
and one virtual server for CAS role.
yes, we will run again preparead commands.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Shouldnt be a problem .....

Yes lets run the preparead command again and restart the Mailbox server if possible ... also make sure the Mailbox Database is mounted and all services running.

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Hope none of the roles failed and no missed E2k10 installations at some time ?
Also can you tell the version of SP and RU on all servers ?
When you try the move you see any eventID at the time of failure in App logs ?

- Rancy
0
 
nivasnetAuthor Commented:
all exchange server sp2... regarding RU i need to check.
i will post error logs soon.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
What happens if you create a new Mailbox on 2010 server and try to move it to a different store ?
What if you create a new mailbox on 2003 and move to E2k10 ?
Hope there isnt any issues on the CAS server ?

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Check this article once

Problems starting MS Exchange Mailbox Replication Service on Exchange 2010
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26164144.html

Microsoft Exchange Mailbox Replication Service should be running on CAS server ..... so maybe some issues with your CAS connectivity

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Please on the CA go to Registry and let me know what do you see under CAS.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ (Client Access)

If possible i would say try and restart the CAS server (VM)

Moving Mailboxes in Exchange 2010 (Part 1)
http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/moving-mailboxes-exchange-2010-part1.html

- Rancy
0
 
nivasnetAuthor Commented:
while moving mailbox we are getting this error application event in exchan
exchange-error.txt
0
 
nivasnetAuthor Commented:
here i am sending registry view
Untitled.jpg
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Seems some issues with your CAS server or its connectivity to other servers ....... did you try restarting the CAS VM ? What DC\GC is listed on the CAS Server properties in EMC ?

CAS is Exchange Server 2010 RTM ? What about the MBX and HUB ?
I guess you would need to Get SP1 on the CAS and other servers if not yet :)

Also did you run setup /preparead ?

- Rancy
0
 
nivasnetAuthor Commented:
yes i run preparead also
all exchange servers sp2
i restarted cas server also
mbx and hub also exchan 2010 sp2
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you tell me the version of Mad.exe on from all the server.

- Rancy
0
 
nivasnetAuthor Commented:
14.2.24.73
0
 
nivasnetAuthor Commented:
i didn't find mad.exe in cas server
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you check the same on Mailbox and HUB server

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ (MBX and HUB) and share the screenshot.

- Rancy
0
 
nivasnetAuthor Commented:
registry view for Hubandtransport
hub-and-transport.jpg
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Your HUB shows 14.2 which is SP 2 for sure ..... but your CAS says 14.0 thats RTM with no SP
:(

- Rancy
0
 
nivasnetAuthor Commented:
ok than i will install sp2 on cas also...is it ok...
0
 
nivasnetAuthor Commented:
Rocking RANCY.,.,.,:,.,.,.,.,.
It is working....
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Awesome very delighted to hear :)

- Rancy
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.