Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3153
  • Last Modified:

Exchange 2010 IIS not working Event ID 5139

Exchange 2010 on Windows 2008 R2 SP2

Exchange is SP2 with Update Rollup 4

After removing the 2003 Exchange server I find I cannot use OWA.  I get the OWA login screen but it says Invalid credentials.
Backgound.  Removed Exchange 2003 and uninstall went smooth.  After removal of 2003 (2003 was installed on Domain controller) demoted domain controller and pointed DMS to existing.
I keep getting error 5139 every 2 seconds ad cannot browse to any other site.  Also created a test site under default web site and cannot browse to it.  Exchange 2010 is the only thing installed on my server (Windows 2008 R2)

The error is: Source: WAS Event ID: 5139

Log Name:      System
Source:        Microsoft-Windows-WAS
Date:          8/19/2012 7:27:20 PM
Event ID:      5139
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      cjmmail01.corp.cjmnetworking.com
A listener channel for protocol 'http' in worker process '7756' serving application pool 'DefaultAppPool' reported a listener channel failure.  The data field contains the error number.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" />
    <EventID Qualifiers="32768">5139</EventID>
    <TimeCreated SystemTime="2012-08-20T02:27:20.000000000Z" />
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Security />
    <Data Name="AppPoolID">DefaultAppPool</Data>
    <Data Name="ProcessID">7756</Data>
    <Data Name="param3">0</Data>
    <Data Name="ProtocolID">http</Data>

The Error in the data is:

-Ran the program err.exe as suggested in another thread and found that 05000780 is Authentication error.
There are no errors in the Application log as suggested in some other thread.
I compared the permissions in IIS and in the c:\program files ....\v14 folder with another working Exchange server and found them to be the same.
I have been doing extensive research in this and have gotten close.  It seems that most of the other errors had matchin2280 errors in the Application log, but mine does not.

Any ideas?


  • 6
  • 3
1 Solution
Can you try the following?

Stop and start the application pool

To stop and start the application pool:

1. Click Start, click Control Panel, and then click Administrative Tools.
2. Right-click Internet Information Services (IIS) Manager and select Run as administrator.
3. In the Connections pane, expand the server node and click Application Pools.
4. On the Application Pools page, select the application pool you want to stop and start.
5. In the Actions pane, do one of the following:
6. Click Stop to stop the application pool.
7. Click Start to start the application pool.

Stop or restart WAS

To stop or restart WAS:

1. Click Start, right-click Computer, and then select Manage.
2. In Server Manager, expand Configuration.
3. Click Services and locate Windows Process Activation Service in the list of services.
4. To stop WAS, right-click Windows Process Activation Service and select Stop.
5. To start WAS, right-click Windows Process Activation Service and select Start.

Start the W3SVC

To start the W3SVC:
1. Open an elevated Command Prompt window. Click Start, point to All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
2. At the command prompt, type net start w3svc.
OWA Virtual directory would be required to point to "MSExchangeOWAAppPool" and not Default Web site, please check the details in IIS and make corrective actions

Ref: link

MDUDLEYAuthor Commented:
Yes the OWA Virtualy directory is set to MSExchangeOWAAppPool
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

MDUDLEYAuthor Commented:
Already researched this - no effect.
MDUDLEYAuthor Commented:
Thanks for all the replies.  This was answered in the technet forum:

Surprising the link doesn't open out here - are you using your partners id to access it?

MDUDLEYAuthor Commented:
Yes it doesn't seem to have an ID or anything .  Here are the keywords:

"Exchange 2010 IIS not working Event ID 5139"
Please paste the solution that helped you.

MDUDLEYAuthor Commented:
Screen shot attached

8/20/2012 solution from MS for Event ID 5139
MDUDLEYAuthor Commented:
This was a solution from the MS forums - not mine.

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now