Outlook 2010 frequently losing connection to Exchange 2010 on SBS 2011

Have a fast ADSL2+ connection  which is connected to SBS 2011 server.  Browsing and all server functions are fast, including RDP.

There have been more and more reports of Outlook Anywhere users losing their connections frequently for periods of 10 sec or 5 min.  Usually disconnects about a dozen times each day.  
Works fine when onsite, but when offsite that is when the issues arrive.  The only similarity between all users would be they are using wireless, but it shouldn't cause this I wouldn't have thought.

MTU of Cisco server router is 1492.  Server NIC MTU size is 1500.  

Please help.
badzsterAsked:
Who is Participating?
 
badzsterAuthor Commented:
Caused by wireless 3G connection when used in tandem with ADSL2 service...
0
 
badzsterAuthor Commented:
Internet works fine at all times...here is the message that keeps appearing.
Untitled.png
0
 
Robert_TurnerCommented:
One basic test you can run from the outlook clients is to right click on the outlook task tray icon, while holding down Ctrl.  You'll get diagnostics for connectivity and outlook anywhere configuration.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Exchange_GeekCommented:
Issue purely belongs to OL loosing connection to CAS Server, so check if you can provide ping round trip counts compared to the time when the issue happens versus when the issue does not happen.

Also check the pings round trip values from CAS to work station for both scenarios.

You might want to check the issue for black hole routers Ref: link

Regards,
Exchange_Geek
0
 
badzsterAuthor Commented:
By running the following:

ping -f -n 1 -l 1465 mailserver

I get a response with the ping from the client, however if I go higher with the mtu (1466) then I receive the message "Packet needs to be fragmented but DF set". Considering the MTU on the modem is 1492, do I need to decrease the MTU on the modem?
0
 
Exchange_GeekCommented:
Yes sir, you definitely need to reduce it to the accepted MTU. This is the famous black hole router issue.

Regards,
Exchange_Geek
0
 
ExchangePanditCommented:
If the above change doesn't work, then please check the below settings which I put it in BOLD, they need to be Ticked:

Outlook 2003

On the Tools menu, click E-mail Accounts.
Click Next.
Select the Exchange account that you want to override the default settings for, and then click Change.
Click More Settings, and then click the Connection tab.
Click Exchange Proxy Settings.
Click to select one of the following check boxes:
On a fast network, connect using HTTP first, and then by using the TCP/IP
On a slow network, connect using HTTP first, and then by using the TCP/IP

Click OK, click Apply, and then click OK.
Click Next, and then click Finish.

Outlook 2007

On the Tools menu, click Account Settings.
On the E-mail tab, click the Exchange account for which you want to override the default settings, and then click Change.
Click More Settings, and then click the Connection tab.
Click Exchange Proxy Settings.
Click to select one of the following check boxes:
On a fast network, connect using HTTP first, and then by using the TCP/IP
On a slow network, connect using HTTP first, and then by using the TCP/IP

Click OK, click Apply, and then click OK.
Click Next, and then click Close.

cheers
0
 
badzsterAuthor Commented:
I don't understand this though:  in the article with the link you gave it makes this comment:
"If the router had been a black hole router, Ping would not be answered once its size exceeded the MTU that the router could handle. Ping can be used in this manner to detect such a router."

Pinging from the client PC across the internet to the mail server using the following command:
ping -f -n 1 -l 1464 mailserver

This works - I get a reply.  


ping -f -n 1 -l 1465 mailserver

This doesn't work - but I still get a 'reply' saying "Packet needs to be fragmented but DF set".



As I understand it, 1464+28 = 1492 which is the default for the Cisco router we have.  Why should I have to change this from the default, and presumably have to change this MTU when it seems to be correct??
0
 
Exchange_GeekCommented:
That is cause possibly we are hinting that on WAN link, the MTU may exceed the 1492 limit.

Read the link for a possible fix and check if this solves your issue.

To understand the default MTU Size, read the link

The above setting would limit the MTU and would always work within the MTU Size the Router understands.

Regards,
Exchange_Geek
0
 
ExchangePanditCommented:
Can you please confirm whether you have checked the settings on outlook which I specified?

Regards
0
 
badzsterAuthor Commented:
End current question
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.