Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

voice vlan for Avaya phone on Catalyst 3560X

Posted on 2012-08-20
17
Medium Priority
?
1,668 Views
Last Modified: 2012-09-05
I have a laer 3 switch 3560X with the following configuration:
MPLS<-->router<-->3560X<-->Avaya phones<-->PCs

 I will have Avaya VoIP phone connected to my 3560X switch. There will be PCs connected to the Avaya phones as well. I am planning to use voice vlan20 and data vlan10 for my interfaces. My management vlan is 100. Will this sample config below work? Do I need to add switchport mode trunk allowed vlan 10,20 and switchport trunk native vlan 10? I know cdp is on by default. But for the Avaya phones, do I need to enable lldp?

interface gig0/2
switchport access vlan 10
switchport mode access
switchport access vlan voice 20

interface gig0/48
description trunk to the router
switchport trunk encapsulation dot1q
switchport mode trunk

vlan 100
description management vlan
ip address 10.10.100.1 255.255.255.0

vlan 20
description voice
ip address 10.10.20.2 255.255.255.0

vlan 10
description data
ip address 10.10.10.2 255.255.255.0

vlan 1
shutdown

default gateway 10.10.10.1
0
Comment
Question by:biggynet
  • 8
  • 7
  • 2
17 Comments
 
LVL 25

Accepted Solution

by:
Ken Boone earned 2000 total points
ID: 38311890
Well my guess is that the Avaya phones do not support CDP.   So given that scenario there are 2 typical ways this is being handled, and it depends on the software version of the phone system and firmware on the phones.  Just recently most of the other phone vendors started moving to lldp.  So you will have to ask the question to your phone vendor as to whether or not your setup will use lldp or not.

If it does not, the typical procedure is that on the data segment dhcp scope there will be certain parameters that will be added.  This is typically a voice vlan ID, a voice PBX IP address, and maybe a QoS setting.   In this model, the phone gets an IP address on the data vlan along with this other information.  The phone then adjusts its settings and reboots.  But this time it tags its traffic in the voice vlan and gets an IP address on the voice vlan.  This is the older method of this working with non cisco phone systems.

The switchports then need to be trunk switchports carrying the voice and the data vlan.

The new way is using lldp, in which case you configure lldp to hand out the voice vlan and qos settings to the phone on the first boot.  This basically mimics what CDP does in the Cisco world.  So if your system supports lldp you can set the port up just like you would for a cisco phone, however, you would need to add the lldp statements.

Hope that helps.
0
 
LVL 10

Expert Comment

by:pclinuxguru
ID: 38312072
Under your voice and data vlans would need the ip helper-address as well as ip directed-broadcast if the phones will be pulling ips via dhcp server so it would look like

Interface vlan20
Description voice
Ip address 10.10.20.2 255.255.255.255.0
Ip helper-address <ip of dhcp server>
Ip directed broadcast

Interface vlan10
Description data
Ip address 10.10.10.2 255.255.255.0
Ip helper-address <ip address of dhcp server>
Ip directed-broadcast
0
 

Author Comment

by:biggynet
ID: 38312675
the dhcp for the voice will be done by the pbx connected directly to the switch. Does the port where the pbx connected to needs to be a voice vlan?
For the data, the dhcp will be done by a dhcp server. the IP helper address will be configured on the router ofr the data dhcp. Will that work?
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
LVL 25

Assisted Solution

by:Ken Boone
Ken Boone earned 2000 total points
ID: 38312698
If the PBX is doing dhcp then it will need to be on the voice vlan.  

Yes the data layer 3 interface will need to have the ip helper pointing to the DHCP server if the DHCP server is not in that data vlan.
0
 

Author Comment

by:biggynet
ID: 38312723
kenboonejr
I am not  a voice guy. So if I understand correctly, if I configure lldp for the Avaya phones, I need to configure my QoS as well. Isn't it simpler if the switch just trusts whatever QoS the Avaya has configured?
0
 
LVL 25

Assisted Solution

by:Ken Boone
Ken Boone earned 2000 total points
ID: 38312747
It depends.. QoS is whole nother bag of tricks really.  Do you need to configure QoS - Yes.   In same the phones already have COS defined for the signalling and voice traffic.  In other cases they use lldp to tell them how to set the COS for the voice packets.    This really isn't the whole qos picture.  This simply tells the phones how to tag the traffic.   I have seen this with shoretel and mitel phones, but I don't remember what Avaya does.  So first off you need to talk with the phone vendor to make sure that what you have supports lldp.  Then configure lldp and get the phones working.  Then you need to configure the switches and routes for qos.
0
 

Author Comment

by:biggynet
ID: 38312837
Yes Avaya supports lldp.
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 38312917
Good then that is the route to take.
0
 

Author Comment

by:biggynet
ID: 38312994
I am a bit confused. So when I configure voice vlan and data vlan on an interface, I am not using lldp. Correct? So if I use lldp, where do voice and data vlan come in? Thanks
0
 
LVL 25

Assisted Solution

by:Ken Boone
Ken Boone earned 2000 total points
ID: 38313343
No voice and data vlan are used in either case.   You use lldp to tell the phone what vlan the voice traffic should be in so the phone then knows to put the voice packets in an 8021.q tagged packet on the voice vlan.

If you don't use lldp, then you either have to hardcode the phones into the appropriate vlans, or use the dhcp method which generally means the phones have to go through 2 boot cycles to get on the right vlan.  

In both cases if you have PCs on a data vlan connected into a phone which should have voice on a voice vlan, you will need to trunk from the switch to the phone.  So you will use a voice and data vlan in both cases.   lldp is just a method to tell the phone what vlan the voice should be in.
0
 

Author Comment

by:biggynet
ID: 38314348
So if I don't use lldp or if lldp does not work for some reason, I have to hardcode the phone into the appropriate vlan. Is there any white paper or tutorial on how to hardcode the phonce into the vlans?
I read some of the voice cisco certified books and I don't think Cisco really explain how to configure lldp and/or harcoded the phone. Did I miss something? Thanks
0
 
LVL 25

Assisted Solution

by:Ken Boone
Ken Boone earned 2000 total points
ID: 38314437
Ok so here is the deal.  This is an avaya issue not a cisco issue.  You need to have the phone vendor tell you how you need to have your switch configured in order to handle the phones.  What I was sharing with you are several different ways that various phone vendors do it.  The last time I dealt with Avaya phones they weren't supporting lldp - but that was several years ago.  In that case the avaya phones had to either be hardcoded to the right vlans, which you would have to find out from avaya how to do that, or we had to set up this whole dhcp thing where the phone gets the vlan info from dhcp and then reboots into the proper vlan.  

The option you need to implement depends on the what the phone vendor says you need to do, not on what Cisco says you need to do.  I'm sure Avaya has documents on how to do what you want to do.

Here is one.  I don't know what phones you are using but check this out.

https://devconnect.avaya.com/public/download/interop/AvayaCiscoLLDP.pdf
0
 
LVL 10

Expert Comment

by:pclinuxguru
ID: 38316848
I've addressed the original question on the Cisco switches. I would recommend posting in the VoIP section http://www.experts-exchange.com/Networking/Telecommunications/IP_Telephony/VoIP/ of EE if you need assistance with actual phones or VoIP.
0
 

Author Comment

by:biggynet
ID: 38317367
How do I move it to the VoIP section
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 38317475
What part are you still having an issue with?
0
 

Author Comment

by:biggynet
ID: 38317934
So to summarize, there are three ways I can go with:
1. If the Avaya phones support lldp or lldp-med, i can use it with my voice vlan (see sample config below)
2. If not and if the pbx is providing dhcp service, I have to hardcode the phone in the voice vlan.
3. If not and if the remote server provide dhcp service, I have to configure the dhcp server with special parameters for the voice.

i have no idea how to implement 2. and 3.


Config of switch with lldp.

lldp run
!
interface gig0/2
switchport access vlan 10
switchport mode access
switchport access vlan voice 20

interface gig0/48
description trunk to the router
switchport trunk encapsulation dot1q
switchport mode trunk

vlan 100
description management vlan
ip address 10.10.100.1 255.255.255.0

vlan 20
description voice
ip address 10.10.20.2 255.255.255.0

vlan 10
description data
ip address 10.10.10.2 255.255.255.0

vlan 1
shutdown

default gateway 10.10.10.1
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 38318327
That looks correct per the document from Avaya as far as using lldp.  

For options 2 & 3 you would have to find out from Avaya.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question