?
Solved

Spooler service not running

Posted on 2012-08-20
7
Medium Priority
?
787 Views
Last Modified: 2012-08-21
I'm using XP SP3.

I've had a Samsung laser printer with this computer for a couple of years, never had a problem before. However today it won't print, the printer is not installed and won't install, and I get the message "Spooler service not running".

I've recently (probably since the last printout) been doing some cleanouts using software called System Mechanic and maybe I was a bit too enthusiastic about getting some of the computer's lost speed back and turned off something I shouldn't have.

I can't do a system restore - it fails (another question has been asked about this)

I've looked at web solutions and they seem to point to the printer. Samsung's Doctor Printer fails to solve it - says it can't communicate with the printer. (Yes the cable is in!)

Any other ideas welcome!
0
Comment
Question by:StuartOrd
7 Comments
 
LVL 13

Expert Comment

by:xDUCKx
ID: 38313799
can you click start -> Run -> Type "Cmd" without the quotes.

At the command prompt type:

net start spooler

If there aren't any errors, try printing again.
0
 
LVL 28

Expert Comment

by:MAS
ID: 38313928
delete all the printers installed first then
install only the printer required and restart print spoiler.
0
 

Author Comment

by:StuartOrd
ID: 38314085
xDUCKx
Thanks, I tried that but got "System error 1068 has occurred. The dependency service or group failed to start". I don't know what this means.

abbasiftt
There are no printers installed (I'm sure I had a couple of others as well as my Samsung, but there are none there now). I tried to install the Samsung again but got the message that this wasn't possible because the spooler was not running.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 39

Expert Comment

by:hdhondt
ID: 38314412
As spooler problems are usually caused by a faulty driver, you need to completely remove the driver before reinstalling. Just deleting the printer and re-adding it will leave some of the old files. Try this:

Go to Printers & Faxes. First delete the printer(s). Then, from the File menu select Server Properties. Click the Drivers tab and remove any instances of the printer(s) from the list.

Then reinstall from the CD or from a downloaded driver.
0
 
LVL 12

Accepted Solution

by:
Sandeep earned 2000 total points
ID: 38315027
As advised in last comment, i would also suggest to reinstall the driver from scratch. Many times the driver cause issue with the Print Spooler service to stop. Once you have correct set of drivers (32 bit or 64 bit) there should not be a problem with spooler service.

When ever you try to start the service manually or after driver installation please make a note for any event (error/warning) in the System Logs. This could give you some idea or way towards resolution as few dependency services are also need to be running for this service to kick off.

http://answers.microsoft.com/en-us/windows/forum/windows_xp-system/print-spooler-error-1068-the-dependency-service-or/399f0ba6-ee10-43b7-a51b-b30bebb56cd9

is one of the example of such service failure.
0
 

Author Comment

by:StuartOrd
ID: 38315104
OK, thanks.
hdhondt: there was no printer in the list to delete, so I went to File / Server properties and got the error box "Server properties cannot be viewed. The print spoooler service is not running".
This stopped spooler seems to be a catch 22. If I try to instal a driver, it says it can't because the spooler isn't running.
reach2sandeep: this seems encouraging. Your link led me to find that my print spooler depends on a lexmark service; I've no idea why, I've never used a Lexmark printer in my life, but maybe it is used by Samsung or some other printer I've used. It wasn't working. I seem to need to reboot so I'll do that now....
0
 

Author Comment

by:StuartOrd
ID: 38315136
....and indeed it worked! I had set these back to automatic, and they now seem to be running OK. On reboot, I find a list of printers (including pdf "printers") all registered and working.

Apart from the nuisance, it was an interesting problem, as I've not seen these services and dependencies before. I'm starting to learn why so many services run in the background when I open Task Manager. I'll be less gung-ho closing things down in future!
Many thanks.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
This article shows how to get a list of available printers for display in a drop-down list, and then to use the selected printer to print an Access report or a Word document filled with Access data, using different syntax as needed for working with …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question