SSIS Developed in Visual Studio 2010 Run on SQL Server 2008

Hi,

I have developed a package in Visual Studio 2010 running over SQL Server 2008. The package debugs and runs absolutely fine, however when I try to schedule the task in SQL Server Agent I get the error 0xC001700A The Version Number in the package is not Valid.

After some research I have determined that this is due to the package being developed in 2010 and running on 2008 - even though the package runs fine everywhere else but in SQL Server Agent.

What can I do about this?

Thanks

Mike
ubya308Asked:
Who is Participating?
 
tim_csCommented:
You can not run a package created in VS 2010 on SQL Server 2008.
0
 
Jason Yousef, MSSr. BI  DeveloperCommented:
VS 2010 data tools is designed for SQL2012.

you can hit SQL 2008 DB as a source and destination, but can't schedule the job using a 2008 agent!

either you e-develop the package in vs 2008 (BIDS), or upgrade to SQL 2012
0
 
tim_csCommented:
You should be able to install BI Development Studio 2008 and build your package with it.  It will have a VS 2008 shell that it will run in so VS 2008 isn't required.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.