• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 522
  • Last Modified:

Joomla com_weblinks shows 'Web link not found' in 2.5.1

Hello - has anyone got any ideas why the com_weblinks has stopped working here:

http://www.fastlane-turnstiles.com/index.php/en/contact/links

I've tried updating the function as proposed here: http://sos82.net/coding/6-joomla-2-5-1-weblink-doesn-t-work.html

...but to no avail

Any help would be appreciated - thanks, Paul
0
Sideas
Asked:
Sideas
  • 5
  • 4
3 Solutions
 
Julian HansenCommented:
Stopped working how ?

Seems to be fine to me.
0
 
joomla_phpCommented:
Have the search engine friendly links settings been changed since those links were created?
Clear Joomla cache for starters. If that doesn't work, post Joomla admin SEF settings and .htaccess contents.
0
 
SideasAuthor Commented:
Hi, joomla_php - yes cleared cache and tried with SEF on and off - both same result.

htaccess.txt is below for you - thanks.

##
# @package		Joomla
# @copyright	Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.
# @license		GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.

Open in new window

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
joomla_phpCommented:
Exactly what are the SEF settings in admin.

FWIW that file is not being run - it's only read when the name is .htaccess (dot htaccess).
0
 
SideasAuthor Commented:
Cheers, put the dot on the filename now.

Here's a screenshot of the SEF settings...

Thanks
Screen-shot-2012-08-21-at-14.56..png
0
 
joomla_phpCommented:
.htaccess, not .htaccess.txt - just checking

So sef is off in the settings, too.

Something is wrong in cache I think because the url's your site is producing are sef but the settings are off in admin, and were off in htaccess.

Do this in this order -
set SEF settings to Yes, Yes, No, No, No
make sure it's .htaccess including dot in file name, no .txt
uncomment line 56 of .htaccess and save

clear joomla cache
clear browser cache

try the page again
0
 
SideasAuthor Commented:
Hello - sorry for the delay.

Did the above but now getting

http://www.fastlane-turnstiles.com/en/component/weblinks/?task=weblink.go&catid=&id=60:exhibitions

500 error...any more ideas??

Thanks a lot
0
 
joomla_phpCommented:
Is there an SEF plugin in there somewhere? That URL looks wrong.
0
 
SideasAuthor Commented:
Hi, yes we've got this installed (screenshot attached)

Are there any known conflicts with the weblinks component do you know?

Thanks again
0
 
SideasAuthor Commented:
Hello

All sorted now.

Issue:- When you hovered over the links in the weblink module, you could see the link stayed the same for each of the links below with a category, this lead to a "weblink not found"  error message. It seemed to be linking to the category not the link itself.


OK, in the end it was not a SEO issue but a module problem, we fixed the linking by following this fix:-

https://github.com/joomla/joomla-cms/pull/109

Before changes:
/component/weblinks/?task=weblink.go&catid=&id=57:fl-distributors

After:
/component/weblinks/?task=weblink.go&catid=57&id=26

It does suggest this has been fixed in later version.

Thanks all.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now