• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 275
  • Last Modified:

SharePoint 2007 WebParts

I am trying to add a webpart that was previously deleted from the page but I get an error message "Cannont Import WebPart" .

How do I fix this?  I can see the custom web part on the Gallery list but I cannot add it to the page.
0
Annette Wilson, MSIS
Asked:
Annette Wilson, MSIS
  • 4
  • 2
1 Solution
 
Rainer JeschorCommented:
Hi,
is this web part working somewhere on another page?
"Cannot load web part" is the common (customizable) error message if SharePoint can not load the artefacts of the web part - most times because either the DLL is not registered as safe, the DLL is missing, wrong assembly versions,...
You may have a look in the SharePoint log:
C:\Progam Files\Common Files\Microsoft Shared\Web Server Extensions\12\Logs

Could you perhaps attach the web part XML from the web part gallery?

HTH
Rainer
0
 
Yagya ShreeCommented:
Found a great post which talks about all the possible method available troubleshooting this issue

Unable to add selected web part(s)
http://social.msdn.microsoft.com/forums/en-US/sharepointdevelopment/thread/a4135afa-a2d0-49f3-a26c-ddc7168d5d8b/
0
 
Annette Wilson, MSISSr. Programmer AnalystAuthor Commented:
Rainerj,

I have attached the xml from the gallery.
WebPart.txt
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
Yagya ShreeCommented:
Did you manager to get an answer for your query?
0
 
Annette Wilson, MSISSr. Programmer AnalystAuthor Commented:
No this is still an oustanding issue.   This web part was functioning well.  I did not understand that it was linked to an external text file that helped with the calculation so the webpart was always showing the incorrect date.  I deleted the webpart then found the external text file.

When I try to add the web part back to the home page, I get an error.
0
 
Annette Wilson, MSISSr. Programmer AnalystAuthor Commented:
I found my solution.  I was able to retrieve my webpart from closed webparts and restore it.  Everything is working now.
0
 
Annette Wilson, MSISSr. Programmer AnalystAuthor Commented:
I was able to work through and find my solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now