• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 13618
  • Last Modified:

Disabling Windows 'Autoconfiguration Enabled'

Hello Experts,

I'm trying manually add an ip address to my adapter settings. However, each time I add an ip address the output in ipconfig/all keeps on providing me with an automatic ip address. I've disabled DHCP Client, but I still keep on getting ip address. Is this of the ' Autoconfiguration Enabled . . . . : Yes'? See below.

Where it states 172.24.16.71(Preferred), does that mean that will be the ip address from now on (at least until I re-enable DHCP?). If I need to get rid of  Autoconfiguration Enabled to allow for manually configuring an ip address can someone please tell me how to get rid of it?

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : A4-BA-DB-B7-93-76
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::3d1a:3f6d:20c:11d1%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 172.24.16.71(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 172.24.16.254
   DHCPv6 IAID . . . . . . . . . . . : 212122331
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-63-89-5D-A4-BA-DB-B7-93-76

   DNS Servers . . . . . . . . . . . : 174.24.1.2
                                       192.168.150.3
   NetBIOS over Tcpip. . . . . . . . : Enabled


I'm running windows 7


Cheers

Carlton
0
cpatte7372
Asked:
cpatte7372
1 Solution
 
gfilipeCommented:
Hi,

You should check:
C:\Windows\System32\Drivers\etc\hosts
this file is the default IP address in case of not attributed address via DHCP.

If this is not the case (in fact I assume not)

You should also try the following procedure:

Type netsh winsock reset in the Command Prompt , and then press the Enter key.
 Do the same process for refreshing the TCP/IP just replace the typed command with.
Then:
netsh interface ipv4 reset   press Enter
 netsh interface ipv6 reset   press Enter
 ipconfig /flushdns   press Enter
 
Restart your Computer.

Once you did, re-add the IP address that you wanted manually.

Hope this helps,
Regards,
GFilipe
0
 
Darr247Commented:
> I've disabled DHCP Client, but I still keep on getting ip address.
Is this of the ' Autoconfiguration Enabled . . . . : Yes'?
No.  Autoconfig range is 169.254.x.x /16 (255.255.0.0).

Just how did you "disabled DHCP Client"?

If you change it from 'Obtain IP address automatically' in IPv4 Properties, windows won't let you close that dialog without entering an IP address.
0
 
gfilipeCommented:
Hi,

Sorry I was not explicit enough, before following the procedure mentioned, please add everything to automatic, meaning:
Obtain IP Address Automatically;
Obtain DNS server address automatically;

Then follow the mentioned procedure.

Regards,
GFilipe
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
David Johnson, CD, MVPOwnerCommented:
Where it states 172.24.16.71(Preferred), does that mean that will be the ip address from now on (at least until I re-enable DHCP?). If I need to get rid of  Autoconfiguration Enabled to allow for manually configuring an ip address can someone please tell me how to get rid of it?

You have setup a static ip address it will stay the same until you change the adapter tcpip/4 properties.

Autoconfiguration only comes into play if all the below are false
(a) static ip address enabled
(b) dhcp did not come back with a valid ip address
0
 
cpatte7372Author Commented:
GFilipe, it worked like a dream.

Cheers

Carlton
0
 
cpatte7372Author Commented:
Cheers mate.
0
 
gfilipeCommented:
cheers mate. Thanks!
0
 
gfilipeCommented:
Hi Vee_Mod,

The solution stated is to add a "static" IP address. But first follow a procedure that uses the "automatic IP":

 "Sorry I was not explicit enough, before following the procedure mentioned, please add everything to automatic, meaning:
Obtain IP Address Automatically;
Obtain DNS server address automatically;

Then follow the mentioned procedure."
+
"You should also try the following procedure:

Type netsh winsock reset in the Command Prompt , and then press the Enter key.
 Do the same process for refreshing the TCP/IP just replace the typed command with.
Then:
netsh interface ipv4 reset   press Enter
 netsh interface ipv6 reset   press Enter
 ipconfig /flushdns   press Enter
 
Restart your Computer.

Once you did, re-add the IP address that you wanted manually."

Note the Last statement  "re-add the IP address that you wanted manually".

Rgds,
GFilipe
0
 
cpatte7372Author Commented:
Hi as I mentioned, the problem was that I wasn't able to manually add an IP address. I tried to add an ip address of say 174.24.15.243, but each time I was given an assigned ip address. I wasn't sure it was because Autoconfiguration was enabled. So if that was the reason I was able to manually assign an IP address then I was asking for help in getting rid of Autoconfiguration. It that wasn't the reason, then I was hoping that someone would show me.

Cheers
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now