Solved

network level authentication for RDP

Posted on 2012-08-21
6
2,199 Views
Last Modified: 2015-08-06
I am running windows server 2008 R2, with the NLA enabled.

On my windows 7 pro desktop, it looks like my NLA is not supported, so how do I install NLA on my PC, so I can RDP into my server?
0
Comment
Question by:afacts
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 6

Expert Comment

by:slidingfox
ID: 38318432
Windows 7 has the Remote Desktop client that supports NLA built in. You shouldn't have to install anything.

Are you getting an error when you try to connect?
0
 
LVL 13

Accepted Solution

by:
Xaelian earned 500 total points
ID: 38318450
Have you configured NLA like this?
http://technet.microsoft.com/en-us/library/cc732713.aspx

Windows 7 has NLA build in, but I've seen your issue before. The following steps will guide you through the process of making it work.

1.Click Start, click Run, type regedit, and then press ENTER.
2.In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3.In the details pane, right-click Security Packages, and then click Modify.
4.In the Value data box, add tspkg. Leave any data that is specific to other SSPs, and then click OK.
5.In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders
6.In the details pane, right-click SecurityProviders, and then click Modify.
7.In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
8.Exit Registry Editor.
9.Restart the computer.
0
 

Author Closing Comment

by:afacts
ID: 38318527
Thanks, the NLA was not supported was my message, but I followd your instructions from 1 to 9, and everything was there, except the credssp.dll (file), I added that, restarted and now it works.   Awesome, somehow the installation got corrupt or something.
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Expert Comment

by:Maybeth
ID: 40918334
I am having the same issue however, when I check my registry settings for Lsa under step 2 I find it already has tspkg and others:
kerberos
msv1_0
schannel
wdigest
tspkg
pku2u
livessp

and when I check the SecurityProviders in step 5, the credssp.dll is already there as well and yet I still cannot connect.  I am using Windows 7 with RDP version 8.1  Any ideas?
0
 

Author Comment

by:afacts
ID: 40918357
Maybeth, I followed this process everytime and it worked everytime.

Have you configured NLA like this?
http://technet.microsoft.com/en-us/library/cc732713.aspx

Windows 7 has NLA build in, but I've seen your issue before. The following steps will guide you through the process of making it work.

1.Click Start, click Run, type regedit, and then press ENTER.
2.In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3.In the details pane, right-click Security Packages, and then click Modify.
4.In the Value data box, add tspkg. Leave any data that is specific to other SSPs, and then click OK.
5.In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders
6.In the details pane, right-click SecurityProviders, and then click Modify.
7.In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
8.Exit Registry Editor.
9.Restart the computer
0
 

Expert Comment

by:Maybeth
ID: 40918379
We do not have RD Session Host Server installed.  The way it was set was through the Remote Settings on the System using the control panel.  We selected the "Allow connections only from computers running Remote Desktop with Network Level Authentication (more secure) on the server.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question