Firewall off, Same Subnet (NO hardware Firewall), Why is Telnet saying "Connection Refused" when I try to connect on a certain port?

Posted on 2012-08-21
Last Modified: 2012-10-02
This is a strange one. I'm trying to communicate between 2 Mac Pro-s, on the same subnet (so NO hardware firewall is between them), software Firewall turned off on both machines. Both are running Lion 10.7.4 (one is Lion Server). So, I'm using a FileMaker plug-in that needs to communicate between the 2 machines using port 51769 and the support folks for this plug-in tells us that if we can telnet between the machines using port 51769, the plug-in will work. Well, I can telnet between the machines fine, I can even telnet each machine locally (, but, when I try to telnet between the machines using port 51769, I get connection refused (same deal when telnet locally each machine What could be blocking this port? No Firewalls anywhere. Is the port blocked on the Ethernet adapter somehow? Is there a Terminal command I need to execute for the Ethernet adapter to allow traffic to pass through this port? Why is telnet refusing this connection? So Weird!! Let me know if anyone has ever run across this problem. I will put the specs of both machines below.  Thanks!!

  Model Name: Mac Pro
  Model Identifier: MacPro1,1
  Processor Name: Dual-Core Intel Xeon
  Processor Speed: 3 GHz
  Number Of Processors: 2
  Total Number Of Cores: 4
  L2 Cache (per processor): 4 MB
  Memory: 5 GB
  Bus Speed: 1.33 GHz
  Boot ROM Version: MP11.005D.B00
  SMC Version (system): 1.7f10
Question by:Julio Garcia
    LVL 24

    Expert Comment

    by:Will Loving
    I'm wondering about the router/switch that the two machines are connected to... Have you tried connecting the two machines directly with a single ethernet cable? It might require a crossover ethernet cable or a simple switch or hub in-between if you don't have a crossover cable (though the ethernet ports may be smart enough to make the connection even without a crossover cable).  If that works then the issue is with the router or switch between the machines.

    Author Comment

    by:Julio Garcia
    oooooohhhhhhh, didn't think about the switches! Wondering now if there would be an issue if multi-cast is enabled or disabled on the switch.

    I do have a crossover cable, going to give that a try.   Thanks!
    LVL 5

    Expert Comment

    by:Feroz Ahmed

    This is something which looks wiered for you as you are not aware of HDD connections there is nothing wiered as both machines are similar the cablin ghsould be cross cabling and whereas when you connect from 2 dissimilar devices you have straigih cabling ,but here in this scenario as both are similar devices the cabling should be cross cabling and not staright cabling and the climping sequence should be accordingly .The climping sequence between 2 similar and dissimlar devices is totally different due to which you are unable to communicate between to similar devices without any hardware firewall or router .check your cabling and it should be cross cabling in case of 2 similar devices and straight cabling in case of 2 dissimilar devices fo communication to take place between devices.which is a part of hardware .
    LVL 24

    Expert Comment

    by:Will Loving
    sm_feroz - some devices, including most current routers and switches as well as the ethernet connections on some computers, are able to auto-detect when similar devices are connected and allow the connection without a cross-over cable. I couldn't remember if the ethernet port on a Mac Pro has this feature which is why I said that a cross-over cable was probably necessary but might not be if Mac Pros had the auto-negotiate feature.

    Author Comment

    by:Julio Garcia
    Thanks Guys!!  Ok, tied them together with a cross-over, was able to telnet each other fine, but still the same results when you telnet port 51769, connection refused. Weird!! I was hoping it was the switch, but looks like it's not. I'm still researching.... I will post if I find anything
    LVL 24

    Accepted Solution

    OK, here are a few more ideas to try.

    1) can  you telnet using a different port, such as FileMaker's default networking port 5003? Try both standard ports and random ones to see if some are blocked and others not

    2) is telnet connection blocked in both directions, meaning initiated from either side?

    3) Look into OS X Server as the possible culprit. Server software in general has higher security needs and more tightly set default settings. OS X Server may be blocking most ports by default. I don't know OS X Server well enough to tell you where to look but the problem is obviously in the configuration of one or both computers and I would start by looking at the server.

    Author Closing Comment

    by:Julio Garcia
    Thanks! Turned out to be none of this actually. Was a java problem with the plug-in

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Computer running slow? Taking forever to open a folder, documents, or any programs that you didn't have an issue with before? Here are a few steps to help speed it up. The programs mentioned below ALL have free versions, you can buy them if you w…
    I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now