• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 367
  • Last Modified:

Report Studio Filter

I'm trying to filter by "is not missing" in a vendor part id field and when I check for errors there are none yet the blank records remain... is this due to the type of field it is?
0
EA_ENT
Asked:
EA_ENT
  • 2
1 Solution
 
RWrigleyCommented:
Is the field actually "Blank"?  Or is it "Null"?  Or is it perhaps a space?  Null fields caused by outer joins won't get "filtered" unless the filter is specified as a summary join.  Often, the easiest way to handle those is to make two sub queries (one for each side of the outer join), and construct the join within report studio directly; this gives you the ability to control the order of filtering.
0
 
EA_ENTAuthor Commented:
To test I tried to just query a seperate report using the field in question and even by itself doesen't work yet no errors at validation.  I did notice when opening in excel some of the records had warnings that a space had been used to start the record.
0
 
EA_ENTAuthor Commented:
I believe the data entry is the problem with that field ...

Thanks
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now