• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1052
  • Last Modified:

VMWare Workstation Linked Clone Disk will not mount, crashes program

I have a VMWare workstation 8 machine using a linked clone file. I tried to copy the vmdk clone file and its parent to a new machine.  Something failed terribly.  Now, when i try to start the virtual machine, the VMWare program just crashes and changes the virtual hard disk to blank in the configuration.  If i try to re-install the disk after it is deleted from the config, i get the error 'the file specified is not a virtual disk'.   If i try to mount the disk, i get an 'error reading volume informaion, please select another disk file.'  I tried running the vmware-vdiskmanager.exe -R command, and it found some errors, but it is still not working.  Please help me repair this so i can get my cloned disk back up and working again.  Thank you in advance.
0
eljasbo
Asked:
eljasbo
1 Solution
 
eljasboAuthor Commented:
i think i just found out the answer to my own question.  When i cloned the file initially, the cloned vmdk child was named the same as the parent.  This must have created a circular reference on the new system where it did not exist on the old one.  I ran the command vmware-vdiskmanager.exe /e on my vdisk, and it showed that the parent file it was looking for was the same name as the cloned file, and it produced a mismatched version error.  I renamed the clone file from vdisk.vmdk to vdisk_new.vmdk, and moved the same named vdisk.vmdk parent file to the same directory and all works fine now, and i get 'disk chain is consistent' when i run vmware-vdiskmanager /e.  I hope this is helpful to anyone else having similar problems.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now