IPV6 and nslookup ?

Anyone can solve this: nslookup cannot work well. after i disable ipv6, it can work well. but then i found that i could not start win 2008, and later i could start it by enabling ipv6 in network adapter. so, before i restart the machine, i need to enable the ipv6. it's complicated, someone have a good idea for this? thank you
davidy2001Asked:
Who is Participating?
 
marsiliesCommented:
Did you create this registry key with the correct value?
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents

You have to edit/create the registry key in order to actually disable IPv6. As mentioned before, simply unchecking IPv6 from the network adapter doesn't disable IPv6, it just unbinds it.
0
 
marsiliesCommented:
What do you mean by "nslookup cannot work well"? Does it return an error, does it just take a long time, or something else?

If Windows 2008 didn't start with IPv6 disabled, how were you able to re-enable it? Did it boot into safe mode, or did you have to do a system restore, or something else?


If you simply unchecked IPv6 in the network adapter properties, it's not disabled, just unbinded. This may be what's causing the boot issues as programs may still be looking for IPv6. You can disable it completely with instructions below.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_26650814.html#a34251052
http://support.microsoft.com/kb/929852

However, IPv6 shouldn't be causing issues with ipconfig,
0
 
davidy2001Author Commented:
Thanks for your reply.
i met the nslookup problem. the link is my post which can tell what it is


http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_27833377.html

that's why i have to uncheck ipv6 in network adapter before i shut the server down. or i have to start the server from safe mode to do that. you see, it is complicated to shutdown

do you have a good idea for that ?
0
 
SteveCommented:
open the properties on your network card(s) and look at the properties for the IPV6 section.

Looks like your system has defaulted to a static DNS server in IPV6. Just set that to 'automatically assign a DNS server and you should be fine.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.