[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6713
  • Last Modified:

Ubiquity UAP-LR Port Issue How to change, what ports should be used?

Hi there,
I have a small network running on SBS 2003.  I recently bought a 3 pack of the Ubiquity UAP-LR Access points.  Upon installing the software on the server (which coordinates and sets the settings for the AP's, It comes up with the following error upon opening.
This is the Unifi Controller application.
Initializing Unifi Controller
Starting Unifi Controller
Port 8081 is used by other programs.

I found info on how to go in and change the ports that are used, but what ports will work that will likely not be used by other programs?

Here is the wiki info
 How can I run UniFi Controller on different ports

    By default, UniFi controller runs on these ports
        unifi.shutdown.port=8081 (for management purpose)
        unifi.http.port=8080 (device inform)
        unifi.https.port=8443 (controller UI / API)
        portal.http.port=8880 (portal redirect port for HTTP)
        portal.https.port=8843 (portal redirect port for HTTPs)
        unifi.db.port=27117 (local-bound port for DB server)
    Follow these steps to change the default settings
        Make sure UniFi is not running
        modify <unifi_base>/data/system.properties and make sure all ports needed by UniFi are available
        restart UniFi

As I am running this on an SBS 2003, I need to not bump into ports that may be in use.
I have a Xywall firewall/router connected to a T-1 if that helps.  Most other things should be fairly standard.

Thanks,
Dave
0
captelcom
Asked:
captelcom
  • 2
  • 2
2 Solutions
 
Rob WilliamsCommented:
I am not familiar with your app, however...
Never use ports below 1024.  SBS uses some ports for IIS, WSUS, and remote access these should be apparent under web sites in the IIS web console.  I would recommend using 9000 and above and you should be fine.
0
 
captelcomAuthor Commented:
Actually I came across some information elsewhere on the web that goes along with what RobWill said.  On two different servers I successfully changed all the 8xxx ports to 9xxx and the software works perfectly now.

From the UNI-fi AP wiki

 How can I run UniFi Controller on different ports

    By default, UniFi controller runs on these ports
        unifi.shutdown.port=8081 (for management purpose)
        unifi.http.port=8080 (device inform)
        unifi.https.port=8443 (controller UI / API)
        portal.http.port=8880 (portal redirect port for HTTP)
        portal.https.port=8843 (portal redirect port for HTTPs)
        unifi.db.port=27117 (local-bound port for DB server)
    Follow these steps to change the default settings
        Make sure UniFi is not running
        modify <unifi_base>/data/system.properties and make sure all ports needed by UniFi are available
        restart UniFi
0
 
Rob WilliamsCommented:
Glad to hear you were able to resolve.
Thanks captelcom.
Cheers!
--Rob
0
 
captelcomAuthor Commented:
My comment provided a complete answer.  Expert comment was correct in that the ports need to be 9000 and above, but not a complete "how-to" that will be useful to future searchers of this information.  Points are appropriately awarded to RobWill
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now