[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4912
  • Last Modified:

nslookup Server Failed

hi,

When using nslookup on windows 2008 to resolve server names, I get Server Failed message unless I specify the FQDN. If I use nslookup on the server itself, everything works fine, on client i try to make sure the DNS Suffix Search List ok and Connection-specific DNS Suffix is Ok, i never face any problem before this suddenly happened , last time i try to change the dynamic update from Nonsecure and secure to secure only , but now i return it back but still i'm getting server failed
0
rasa78
Asked:
rasa78
  • 6
  • 6
1 Solution
 
footechCommented:
Can you provide the output (copy and paste, don't summarize) of using nslookup on both a client and server (i.e. one works and the other doesn't).  It'll be better than guessing at what you are actually seeing.
0
 
rasa78Author Commented:
hi footech,

thanks for your help,

If I use nslookup on my machine or any machine on workgroup not join domain it is not working , but with FQDN it is working fine:

Default Server:  dc.abc.local
Address:  192.168.1.184

> dc
Server:  dc.abc.local
Address:  192.168.1.184

*** dc.abc.local can't find ad: Server failed
> dc.abc.local
Server:  dc.abc.local
Address:  192.168.1.184

Name:    dc.abc.local
Address:  192.168.1.184

>

If I use nslookup on the server itself on any machine join domain, everything works fine:

Default Server:  dc.abc.local
Address:  192.168.1.184

> dc
Server:  dc.abc.local
Address:  192.168.1.184

Name:    dc.abc.local
Address:  192.168.1.184

>

Note: i have two DNS server and when i'm doing monitoring on the dc

simple query against PASS and recursive query to other DNS failed

on the dc2 the both of them are failed, i checked the firewall and nothing are ON

dc is windows 2008 enterprise 32bit
dc2 is windows 2008 enterprise 64bit
0
 
footechCommented:
The monitoring tests are a bit troubling, but I don't think it's related, so let's deal with the workstations which are part of a workgroup first.

Can you post the contents of running the following inside of a nslookup prompt?
set all

and also the results of ipconfig /all?  I'd like to verify the connection-specific DNS suffix and DNS suffix search list.  Never hurts to have another pair of eyes.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
rasa78Author Commented:
Hi,

thanks for your support, and sorry i'm using dummy name and ip

for ipconfig /all

Windows IP Configuration



        Host Name . . . . . . . . . . . . : work-pc

        Primary Dns Suffix  . . . . . . . :

        Node Type . . . . . . . . . . . . : Hybrid

        IP Routing Enabled. . . . . . . . : No

        WINS Proxy Enabled. . . . . . . . : No

        DNS Suffix Search List. . . . . . : abc.local





Ethernet adapter VLAN 1:



        Connection-specific DNS Suffix  . : abc.local

        Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet

        Physical Address. . . . . . . . . : 00-15-77-D3-CA-26

        Dhcp Enabled. . . . . . . . . . . : No

        IP Address. . . . . . . . . . . . : 192.168.4.60

        Subnet Mask . . . . . . . . . . . : 255.255.0.0

        Default Gateway . . . . . . . . . :

        DNS Servers . . . . . . . . . . . : 192.168.1.184

                                            192.168.1.185


for nslookup set all

> set all
Default Server:  dc.abc.local
Address:  192.168.1.184

Set options:
  nodebug
  defname
  search
  recurse
  nod2
  novc
  noignoretc
  port=53
  type=A
  class=IN
  timeout=2
  retry=1
  root=A.ROOT-SERVERS.NET.
  domain=
  MSxfr
  IXFRversion=1
  srchlist=
0
 
footechCommented:
Well, I see an issue, but not sure of the cause.  In the nslookup results, the "srchlist" entry is empty, as is the "domain" entry.  Even on a workgroup machine, the domain entry should be the first entry that is present in the srchlist.  You could actually set this manually by entering "set srchlist=abc.local" but that only lasts for nslookup session.

What OS are the workstations running?
What options are checked under TCP/IP properties of your NIC > Advanced > DNS tab?
0
 
rasa78Author Commented:
Hi,

the OS is windows XP and windows 7 also have the same problem,
and the options checked under TCP/IP properties of your NIC > Advanced > DNS tab is :

Append primary and connection specific DNS suffixes
Append parent suffixes of the primary DNS suffix
DNS suffix for this connection: abc.local
Register this connection's addresses in DNS
Use this connection's DNS suffix in DNS registration

for the srchlist i enter it manually and it is working fine, how to make this automatically

Thanks for your support
0
 
footechCommented:
Instead of checking "Append primary and connection specific DNS suffixes", try checking "Use these DNS suffixes (in order)" and add your domain in the list there.  Then relaunch nslookup and see if the srchlist entry has the correct info.
0
 
rasa78Author Commented:
I will check it and let you know, but what about the remote sites? Because before it was working fine .
0
 
footechCommented:
OK.  I was able to duplicate your results.  When I set a static IP on a workgroup machine, I get the same as you.  It doesn't seem to use what's set for "DNS suffix set for this connection".  What does work is to set "Append these DNS suffixes" or setting the primary DNS suffix in the same area that you set a machine's name and workgroup or domain membership.

Don't know why this is (sounds like a bug) or how it could have been working for you earlier.  The other option I see for you is to use DHCP.

In either case, what I see is that nslookup won't append the DNS suffix with your current settings, but normal DNS operations should.  For example, using ping and just entering the NetBIOS name.  So although nslookup may not work for you at these workgroup machines when using a single label name, normal DNS resolution should work fine.  What's the end goal here, just to use nslookup, or are you having some other issue with the machines?
0
 
rasa78Author Commented:
just having problem with nslookup only, because what's happened with me some time the remote sites take time to resolve the DNS till I explain to the user to do ipconfig /flushdns every time , than i found that the problem in DNS and it is not working properly to resolve the name wich is working fine before may be there is bug as you say ! i try to "Use these DNS suffixes (in order) it is working fine also from DHCP working fine , what you suggest ?

Thanks for your help
0
 
footechCommented:
Whether it is a bug, an oversight in how nslookup was designed, or intentional, what you're seeing with nslookup (as mentioned in your original question) is its normal expected behavior.  I don't believe that nslookup would have appended any DNS suffixes in the past unless the configuration was different.  Using any of the 3 options (Use these DNS suffixes; setting primary DNS suffix; DHCP) is a valid solution.  Which one is best depends on you.

The next question is whether putting any of these options in place will have any effect on the workstations that are having problems at your remote sites.  I don't think the nslookup results are related, as nslookup uses its own DNS resolver that is different from the rest of the OS.  But you can try putting any of the 3 options into place on a few machines and see if it resolves the problem so clients no longer have to do an ipconfig /flushdns.  It's possible that the problem is related to the failure of your DNS servers with the monitoring tests.

If I were you I would open a new question that describes exactly the problem you're trying to resolve.  Mention the workaround you've found of using ipconfig /flushdns and what you've seen on the servers, and any other detail possible on how long the issue has been happening, what you've done so far, etc.
0
 
rasa78Author Commented:
ok, thanks for your time and your help :)
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now