Site-2-Site VPN between ASA 5505 and draytek, cant reach public ip from draytek when i'm in the ASA network

Posted on 2012-08-23
Last Modified: 2012-09-01

i have a strange problem. I've set up a VPN connection between a Cisco ASA 5505 and a draytek router. Everythin is working ok at least of this:

When i'm behind the Cisco ASA i cannot reach the external IP (public IP) of the draytek. I recieve an error:

Type - VPN --> Subtype - encrypt --> Action - Drop

When i do a TCP traceroute.

What did i do wrong?

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.08.23 14:13:13 =~=~=~=~=~=~=~=~=~=~=~=

: Saved
ASA Version 8.2(5) 
domain-name rienksbm.local
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
name draytek-network
interface Ethernet0/0
 switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
<--- More --->
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
interface Vlan1
 nameif inside
 security-level 100
 ip address 
interface Vlan2
 nameif internet
 security-level 0
 ip address *.*.*.* 
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns server-group DefaultDNS
 domain-name **************

access-list internet_access_in extended permit icmp any any echo-reply 
access-list internet_access_in extended permit icmp any any unreachable 
access-list internet_access_in extended permit icmp any any time-exceeded 
access-list internet_access_in extended permit ip draytek-network 
access-list internet_1_cryptomap extended permit ip draytek-network 
access-list inside_nat0_outbound extended permit ip draytek-network 
access-list inside_access_in extended permit ip draytek-network 
access-list inside_access_in extended permit ip any any 
pager lines 24
logging enable
logging asdm notifications
mtu inside 1500
mtu internet 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (internet) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1
access-group inside_access_in in interface inside
access-group internet_access_in in interface internet
route internet 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL 
http server enable 8443
http server idle-timeout 15
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map internet_map 1 match address internet_1_cryptomap
crypto map internet_map 1 set connection-type answer-only
crypto map internet_map 1 set peer *.*.*.* 
crypto map internet_map 1 set transform-set ESP-3DES-MD5
crypto map internet_map interface internet
crypto isakmp enable internet
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
telnet timeout 5
ssh inside
ssh timeout 15
ssh version 2
console timeout 0
dhcpd dns interface inside
<--- More --->

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server source internet prefer
ntp server source internet
username admin password 4SZYTvE5FACoOaFz encrypted privilege 15
tunnel-group type ipsec-l2l
tunnel-group ipsec-attributes
 pre-shared-key *****
class-map inspection_default
 match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous

Open in new window

Question by:computication
    LVL 57

    Expert Comment

    by:Pete Long
    try adding

    policy-map global_policy
     class inspection_default
       inspect icmp
    LVL 3

    Author Comment

    Thanks for your reply but nothing is changed. I've added soms screenshots so you can see what happens.

    As you can see, when i try to reach the external IP it gives me the error when i try to connect trough the VPN tunnel is works well.

    From another location i can reach the external IP of the draytek. No firewall issue over there.
    LVL 3

    Author Comment

    I've found another error message when i try to connect to the external IP of the draytek:

    3    Aug 23 2012	17:47:13	   IKE Initiator unable to find policy: Intf inside, Src:, Dst:

    Open in new window

    LVL 18

    Expert Comment

    I think you need to add dreytek public IP address to your cryptomap and nat exempt
    LVL 3

    Accepted Solution

    I tried but it didn't worked..

    I don't know why, because it worked for a long time..

    I removed the whole vpn configuration from the ASA and reconfigured it, after that it worked fine. Configuration looks the same for me but it works ok now.
    LVL 3

    Author Closing Comment

    It was going wrong somewhere in the NAT configuration. I couldn't solve it so i tried a reconfiguration, that seems to work for now.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
    Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now