[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 691
  • Last Modified:

SQL 2008 R2 Mixed Mode Auth Login Username

Heyas,

I just installed SQL server and I chose mixed auth during the install. I only specified the password during the install where would I find the username I supposed to use. Refer to screenshot below

Thank you.
Capture3.PNG
0
Zack
Asked:
Zack
1 Solution
 
John JenningsOwnerCommented:
Using mixed mode authentication, you have two options:

1. You can sign in using your windows username and password.
example: domain\username
2. You can use the "SQL Admin" account and SQL authentication.
example: default sql admin account is called "sa" - but that in user field.


So, either login with your Windows credentials, or login with user "sa" and the password you specified.
0
 
AnujCommented:
The password you specified at the time of installation is for 'SA' Account, the is a default system admin account comes with SQL Server and has all permissions. So choose "sa" in the username, and the password is the one you provided during setup.
0
 
Vijaya Reddy Pinnapa ReddyCommented:
Usename is sa
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
ZackGeneral IT Goto GuyAuthor Commented:
HI guys tried not working any other ideas.

Thank you.
0
 
TI2HeavenCommented:
Even when you set sa password, it might be disable until you enable it. So use Terminal Server to log into the SQL server as administrator and then open management studio. At the prompt change the authentication type to Windows.
Then go to security->logins and check if sa is enable.
Enable it if you want to use sa to access SQL server.
0
 
John JenningsOwnerCommented:
You really should just sign in with Windows authentication. Use the account that you were signed in as when you installed SQL.

Using SQL authentication is best reserved for applications themselves.
0
 
ZackGeneral IT Goto GuyAuthor Commented:
Cheers man that fixed it.

Additionally here is a great post that explains the issue in detail.

http://www.dekho.com.au/enabling-mixed-mode-authentication-on-sql-server-after-installed-with-windows-authenication-mode/
0
 
John JenningsOwnerCommented:
If that blog post explains your problem, then your original question wasn't accurate. Had you actually installed SQL in mixed mode, the 'sa' account would've been enabled automatically.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now