Unwritten Logs in Oracle

Posted on 2012-08-23
Last Modified: 2012-09-20
I have a proc which writes to a log file.

Sometimes i see that log is not written even through the procedure ran successfully. I know
since tables are populated.

What can be the reason behind this?
Question by:gram77
    LVL 76

    Expert Comment

    by:slightwv (䄆 Netminder)
    We would probably need to see the code but could it be some exception after the update but before the log write?

    Is it possible that log is getting over-written?  Possibly with the procedure being run twice at the same time?

    Author Comment

    I was told it was due to faulty index in the table. But what has index to do with write operation?
    LVL 76

    Accepted Solution

    >>But what has index to do with write operation?

    It depends.  If the bad index caused some error, it might raise an error after the update and before the write.

    If you were told why it didn't write to the log, whoever told you this should be able to explain why the update worked and the write didn't.

    Author Comment

    During an insert what will be updated. As i know during an insert both table and index will be inserted with the row. What will be updated here?
    LVL 76

    Expert Comment

    by:slightwv (䄆 Netminder)
    I was using 'update' as a general term for a change to the database.  I don't know what your procedure does before it inserts into the log.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    PRTG Network Monitor: Intuitive Network Monitoring

    Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

    Suggested Solutions

    Working with Network Access Control Lists in Oracle 11g (part 1) Part 2: So, you upgraded to a shiny new 11g database and all of a sudden every program that used UTL_MAIL, UTL_SMTP, UTL_TCP, UTL_HTTP or any oth…
    Background In several of the companies I have worked for, I noticed that corporate reporting is off loaded from the production database and done mainly on a clone database which needs to be kept up to date daily by various means, be it a logical…
    This video shows how to Export data from an Oracle database using the Datapump Export Utility.  The corresponding Datapump Import utility is also discussed and demonstrated.
    This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now