Intervlan

I have a PC connected to a Catalyst 3560 switch and nothing else is connected to the Catalyst. The PC can ping  10.10.100.1 but not 10.10.200.1 & 10.10.10.2. Not sure why as I already have my ip routing on.

My PC is 10.10.100.200/24. My vlans are:
vlan 10 - 10.10.100.0/24
vlan 20 - 10.10.200.0/24
vlan 1 10.10.10.2/24

Below is the simplified version of my L3 switch:

ip routing

int fa0/1
description connected to the PC
switchport access vlan 10
switchport mode access
...
int vlan 10
ip address 10.10.100.1/24

int vlan 20
ip address 10.10.200.1/24

int vlan 1
ip address 10.10.10.2/24
biggynetAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
unfragmentedConnect With a Mentor Commented:
You have nothing else plugged into the switch.
That means there are no active ports in vlan 20 or vlan 1.
The switch will therefore set the SVIs vlan 1 and vlan 20 to down, hence they will not respond.

do a 'show ip int brief' at the CLI and you will see what I mean.

You can fix it by assigning a ports to vlan 1 and vlan 20, and plugging something into them.  You could also create a trunk port and plug something into it.
You could also disable autostate on the vlan interface.
0
 
xDUCKxCommented:
ip route 10.10.100.0 255.255.255.0 10.10.100.1
ip route 10.10.200.0 255.255.255.0 10.10.200.1
ip route 10.10.10.0 255.255.255.0 10.10.10.1

If you're using an access-lists to filter traffic:

int vlan 10
ip address 10.10.100.1/24
ip policy route-map 101

access-list 101 permit tcp any any
access-list 101 permit udp any any
access-list 101 permit icmp any any
etc etc
0
 
biggynetAuthor Commented:
ip route 10.10.100.0 255.255.255.0 10.10.100.1 did not work. The error is invalid next hop address (it's the router)
0
All Courses

From novice to tech pro — start learning today.