• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 440
  • Last Modified:

Missing email mystery...

Here's the timeline:

June 16, I installed a new exchange server.  It's a VM running in Hyper-V on Server 08, R2.

July 13, there's a power outage (massive) and the physical host, and of course all of the VMs, go down ungracefully.

July 13, everything is back up EXCEPT, in Hyper-V, the exchange server is missing.  I created a new VM, pointed to my Exchange VHD, and spun it back up.  Mail was flowing.

Aug 20, the Exchange VM mysteriously goes away!  We create another new VM, point to the Exchange vhd, and we are back up.

I learn that I had AV installed on the physical and that the AV was scanning my xml and vhd files and interpreting the xml as "virus-like and quarantining them.  So, I exclude xml and vhd files from AV scan and get my exchange server back up.

Here’s the mystery…

For every user, the user is missing emails for July 13 thru Aug 6.  Now remember the power outage started on July 13, so that data sort of makes sense, but the next outage was on Aug 20.  Still, I have verified that there is no mail for July 13, thru Aug 6.  No sent mail, no received mail, no deleted mail for those dates.

There is only one VHD so I know I didn’t attach the wrong one.

Mail flowed fully from July 13 until Aug 20, but on the 7/13 thru 8/6 email is missing.

Ideas?

Thanks

Cliff
0
crp0499
Asked:
crp0499
  • 3
  • 2
  • 2
2 Solutions
 
S_K_SCommented:
1st Outage on 13th July and 2nd Outage was on 20th August and emails missing between 7/13 thru 8/6...need to know if emails from 8/6 are present or they too are missing.

If all emails missing then I'd say that the VHD that was loaded on 20th August had the old database which was dated 13th July.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Firstly do you have a backup of Exchange DB or the VHD's ?

First Outage on July 13th
Second Outage on August 20th

You recovered the VHD for 20th ..... the emails are missing from 13th July to 6th August ?
Thats a bit strange as the data in the VHD is till 20th day you recovered it from the AV.

Also do you have the Log files from that days when you say the emails are missing ?

- Rancy
0
 
crp0499Author Commented:
S_K_S - yes, emails from 8/6 forward are present.  there is only one VHD and only one database.  kinda hard to say I attached to the wrong vhd or database.  of course I had checked all of that.

Rancy - Sadly, no.  The server is new and I have not set up backups yet.  I have one VHD and it's the original vhd i started with on 06/13 when I installed the server.  the emails from the 08/06 forward are there.  No log files, but I had looked at them and saw nothing, I mean zero worth looking at.
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
S_K_SCommented:
Well crp0499...sadly I need to say nothing can be done here as you say you have no backups and no log files to try doing the replay of log files to re-cover missing emails and you confirm that the only VHD you had was used hence no chance of wrong VHD in use

One thing that can be tried here is you try logging into individual user mailboxes and check for the option RecoverDeletedItems from Outlook and see if any data can be recovered...however I dont see much of a chance with this either...

Can only say one thing...plan out for backup schedules going forward
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
crp0499: Is it Exchange 2007\2010 ... i would suggest you to have another VHD if possible and have a new Mailbox database on it and create a LAG if Exchange 2007 if Exchange 2010 then have Journaling as this would ensure secondary copy of the data on another location.

Anyways as you have already set exclusions you should be good ..... but No Backups nor copy is going to hit hard if for whatever this happens again and you loose huge chunk of data :(

- Rancy
0
 
crp0499Author Commented:
yeah, i'm with you.  it's a new box and new exchange, so i just hadn't gotten to a proper setup.  there is ONLY ONE vhd.  of that I am certain.  it's just a very odd thing.  thanks guys.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
The only issue is there is a lot of limitations but .... best thing is moving ahead to plan for better .... if its W2k8R2 you should be able to take Online exchange backups as well.

- Rancy
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now