Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 850
  • Last Modified:

how to mailmerge Word 2003

I keep messing up configuring Mail Merge which I seem to find the absolutely most difficult piece of Microsoftware to figure out -- which is saying something!

I have a merge document that I somehow figured out how to create once upon a time. I want to change the data source. I go to Tools > Letters and Mailings > Mail Merge, run through the wizard and end up with a merged document of the 1st row only of my merge data file. When I save the document, my original apparently get clobbered because when I pull it back up my merge fields are gone and the 1st data row is merged, regardless of how I answer the "Opening this document will run the following SQL command". If I change the data source contents, I still get the old 1st record in when I open the doc, new contents are ignored.

Once again, I CANNOT seem to figure out how to change the merge datasource without destroying the merge fields.

I would appreciate help ... AGAIN! This time I'll write down the proecedure!
0
jmarkfoley
Asked:
jmarkfoley
  • 4
  • 3
  • 2
3 Solutions
 
John HurstBusiness Consultant (Owner)Commented:
Here is a set of instructions I gave a person who was afraid of computers and it worked for him.

1. Start Excel with Christmas list and review the base list. Make any changes, save, and close Excel.

2. Start Word

3. On Tools Menu, point to Letters and Mailings and then click on Mail Merge Wizard

4. Mail Merge Wizard steps.
(i) Select Labels and Click on Next on Bottom
(ii) Select Change Document Layout, click on Label options and Select type 8160
(iii) Select Recipients, use existing list, select Browse, click on Desktop and select Christmas Address List (or other list)
    Use First Address Table list and click on OK. See that the whole list is already selected and click OK
(iv) Arrange Labels
    Note: Place cursor in the first label on the screen (which is blank) and not any other label.
    Click on More Items which shows Insert Merge Fields.
    Select all given fields using Insert button or double clicking on each field.
    Notice the fields are now in the first label.
    Edit label
    Click on Update all labels
(v) Preview
(vi) Complete merge and print.

Note the italicized steps, especially the Update all labels step.

Print this out, step through it, make changes for yourself to document and please let us know.

.... Thinkpads_User
0
 
GrahamSkanCommented:
It isn't clear that you are actually executing the merge, as opposed to previewing it. The <<abc>> button on the Mail Merge toolbar is used to switch between displaying the merge fields and previewing the results in the place of the fields. You can step through the records in the preview mode.

The mail merge main document acts like a template, in that it does not get modified by the execution process.

Once designed, the document is used to produce the merge output to fax, printer, email, or to a new result document. The last is a separate document from the main document. As I recall, in Word 2003, one of the four buttons on the right of the toolbar will execute the merge to its respective destination.

The message "Opening this document will run the following SQL command" is a security warning which (unless you have applied a registry patch) always comes up when opening a mail merge main document
0
 
jmarkfoleyAuthor Commented:
thinkpads_user: I followed your steps:

> 1. Start Excel with Christmas list and review the base list. Make any changes, save, and close Excel.

I already have a .csv file, so I skipped step 1.

> 4(i) Select Labels and Click on Next on Bottom

I am doing a letter, so I left 'document type' set to "Letters", skipped your step 4(i) and 4(ii) (Change document layout) and went to 'Next' Starting the document.

I already have a merge doc I've been using successfully so I left 'Use the current document selected' and clicked 'Next'.

> 4(iii) Select Recipients, use existing list, select Browse, click on Desktop and select Christmas Address List (or other list)

Did that. Selected my .csv file.

> Use First Address Table list and click on OK. See that the whole list is already selected and click OK

I did the select all -- I hadn't done that before. Clicked OK.

> (iv) Arrange Labels
>    Note: Place cursor in the first label on the screen (which is blank) and not any other label.

I'm doing a letter, so I don't appear to be able to do this.


> Click on More Items which shows Insert Merge Fields.

Don't have a 'More Items' button/link that I can see

> Select all given fields using Insert button or double clicking on each field.
>    Notice the fields are now in the first label.

Double clicking on each field does nothing.

> Edit label
> Click on Update all labels

Perhaps this corresponds the the 'Write your letter' link in the wizard if one is doing a letter instead of labels? I do that, but of course the letter is already written. I have a link 'Preview ...'

> (v) Preview

I click the 'Preview your Letter' link. and can see each recipient. Certainly selecting all recipient in the list helped get more than just the first one.

> (vi) Complete merge and print.

I clicked complete the merge.

But now what? Do I save the document now that my merge page is supposedly in there? You didn't say how to finish up. Perhaps an example using a letter instead of labels would have been easier to follow. Note that I am not interested in have the users of this document go through this absurdly time consuming procedure each time. I am going to (hopefully) have a macro auto-merge things when I get the doc set up.

Anyway, I did save it and when I open it up again, sure enough, the 1st row only already appears to be merge and my merge-fields are no longer obvious. However, when I go through the procedure again and select a different set of records from the list at step 3 of 6: 'Select Recipients' > Browse, my merge fields do suddenly reappear.

So, does that seem normal? Seems like strange behavoir to me.

GrahamSkan: > It isn't clear that you are actually executing the merge, as opposed to previewing it.

I agree. I am unclear as to what I am doing. I'm trying to provide a description of my steps so someone can clarify to ME!

> The mail merge main document acts like a template, in that it does not get modified by the execution process.

If the document does not get modified, why does it appear to auto-merge the first row from my data source instead of leaving the merge fields showing between their <<brackets>>? Is this just Microsoft's way and I have to have faith that the merge fields are still there?

> The <<abc>> button on the Mail Merge toolbar is used to switch between displaying the merge fields and previewing the results in the place of the fields

Unless I change the datasource as I mention above at step 3 of 6 in the wizard, this button is grayed out and I cannot see my merge fields. If I change my datasource, I can see the button and it does work as you state.
 
> The message "Opening this document will run the following SQL command" is a security warning which (unless you have applied a registry patch) always comes up when opening a mail merge main document

When I get this figured out, I'll search for this patch. However, since I saved the document after following thinkpads_user's suggestion  I don't see this message anymore. Another sign I've done something wrong?

So, bottom line: Is what I am seeing "normal / correct" or not? Should I not have saved the document after running through thinkpads_user's procedure?
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
John HurstBusiness Consultant (Owner)Commented:
I already have a .csv file

Try using the Excel file as it has more intelligence for Word to use.  I also keep my source document closed when merging (at least that is what I recall). Word does not need it open to read the file.

Do I save the document now that my merge page is supposedly in there?

I think you can (and probably should). I did not because I was creating labels and once printed, the document was no longer relevant.

So, does that seem normal? Seems like strange behavoir to me.

The behaviour seemed strange to me, which is why I documented the steps to help me run the wizard for the user. All that is now long gone.

Is what I am seeing "normal / correct" or not?

It seems to be correct so far as I can follow. It is different than what I did.

Should I not have saved the document after running through thinkpads_user's procedure?

I actually do not think it matters, but try it both ways and use what works.

... Thinkpads_User
0
 
GrahamSkanCommented:
If you save the Main document, it should remember that it is such, and will have the datasource set.
Then next time that it opens, you will get the security message, and the Preview button will be enabled. You should be able to run the merge straight away without setting the datasource again, just by clicking on one of the buttons on the right of the toolbar.
0
 
jmarkfoleyAuthor Commented:
thinkpads_user: > Try using the Excel file as it has more intelligence for Word to use.

The CSV file will be generated by another program for use in this merge, so I don't really have a choice. Actually, it seems to merge the data fine, so I don't think I need "more intelligence", at least not with respect to the date -- with respect to myself, perhaps.

GrahamSkan: > Then next time that it opens, you will get the security message, and the Preview button will be enabled.

Thatis certainly not what happens in this case. I get no security message and when I open the document the first data row shows in the merge fields and the Mail Merge toolbar is grayed out. I have to click Tools > Letters and Mailings > Mail Merge, to get anything on the Mail Merge toolbar to be enabled, and then  it is only the 'Insert Word Field' control. I have to go through all the wizard steps to effect the merge, including having to re-select my source. The image below shows my document immedidately after I open it. Notice that the merge toolbar is grayed out. The name and address content shown in the letter are all merge fields. The document's merge fields are filled in with the first-only data row. If I open the merge wizard and proceed to step 3 of 6 and re-select my data source (no option to keep the same source), then the merge fields reappear. See 2nd image.

I have followed thinkpads_user's and other similar instructions and end up at the same place, always. The fact that my merge tool bar is inactive when I open the document and that I *always* have to run through the wizard seems odd to me.

Here is what I eventually am trying to do ...

This document (and others) have been used w/o problem from Access for a long time - years. Access provided VBA routines to do the merge operation so that the user only had to run the form and "poof", the merge document appeared. We are migrating away from Access and I am trying to get these documents working as standalone merge docs. It will be unacceptable for the user to have to run through the merge wizard each time. If I can ever get the document set up correctly I will then add a macro to auto-merge the document. I've found such a macro, but of course, I am having trouble getting it working. I don't think that should be part of this question so I've created another question for the macro: http://www.experts-exchange.com/Software/Office_Productivity/Office_Suites/MS_Office/Word/Q_27846473.html

I don't feel confident that I've got the document's merge source set up correctly, so I'm leaving this question open for futher sage input on this topic. Meanwhile, I'll *assume* the document is useable and see if the macro bit works.

Please continue to give your thoughts on this question and check out the macro question as well if you are so inclinded. THX
openMergeDoc.jpg
mergeDocWizard.jpg
0
 
jmarkfoleyAuthor Commented:
More info: I started over. I was somewhat mistaken on saying that the entire mail merge toolbar is grayed out. Barely visible in my openMergeDoc.jpg image is the 'Open Data Source' button on that toolbar which is NOT grayed out. So, with a fresh document, instead of going through the wizard, I simply clicked this button, specified my data source and saved the doc. Now, I do get the "Data from your database will be placed in the document" warning each time. Answering "yes" DOES NOT auto-merge and I do get the merge tool bar enabled. I can then click on 'view merged data', etc. What I'm doing wrong using the so-called wizard, I can't figure out, but at least I think I have the merge doc set up OK.

I'll still leave this open pending feedback on the macro question since they are linked.
0
 
John HurstBusiness Consultant (Owner)Commented:
Thank you and thanks for the update. .... Thinkpads_User
0
 
jmarkfoleyAuthor Commented:
What worked for me was to NOT use the wizard and to simply click on the 'Open Data Source' button on the merge toolbar. The wizard is probably great for doing a one-off merge whereby the user had to follow the "6 steps", but this procedure left my merge-document in some state that totally confused me and appeared to modify the target document.<br /><br />Thanks for your help.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now