• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3297
  • Last Modified:

UltraVNC Authentication issue

Say, Under Admin Properties changed password. When trying to connect I get authentication failure. Ive changed password to "1" and same error.
Any suggestions as to how to resolve.
Using default settings and version:10.9.6.1
0
shaunwingin
Asked:
shaunwingin
  • 7
  • 7
2 Solutions
 
emilgasCommented:
Remove the checkbox DSMPlugin
0
 
shaunwinginAuthor Commented:
Tried this but same error
0
 
shaunwinginAuthor Commented:
My connection string is PublicIP::port and I get this error - there is a nat rule on the router to translate port to 5900. When I connect using the local ip::5900 the password is accepted...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
emilgasCommented:
That tells you that something is not correctly set up on the router. What other ports are being forwarded on the router? What kind of a router is that?
0
 
shaunwinginAuthor Commented:
Mikrotik Router. Forwarding 5901 to IP1; 5902 to IP2 and 5903 to IP3 each IP is on a different PC running VNC and listening on auto. I therefore translate 590x to 5900. Interestingly enough the 5902 /IP2 works remotely to the PC2 - but not the 5901 and 5903. I've checked routers settings and stumped. Issue persists even if PC2 is off.
0
 
emilgasCommented:
so you manually set the PC1 to run the VNC server on 5901? in that case why is the listening on auto?
0
 
shaunwinginAuthor Commented:
no - they all listen on 5900. I set nat rule to direct to IP of PC and Port 5900
0
 
emilgasCommented:
so in that case you can connect to one computer at a time and that's why only PC2 was working
0
 
shaunwinginAuthor Commented:
Say, perhaps if I change listen to port in VNC will solve. How do I do this?
0
 
emilgasCommented:
Hum... I'm sure there is a way but try searching online. Search for your specific version of VNC since there is the RealVNC UltraVNC TightVNC and many others
0
 
shaunwinginAuthor Commented:
I can't believe that UltraVNC doesn't allow one to specify a listen port....
0
 
emilgasCommented:
what about a command line installation?
0
 
shaunwinginAuthor Commented:
sure..how please?
0
 
emilgasCommented:
You can add the line PortNumber=0  to ultravnc.ini
0 means default port which is 5900, so replace it with what you want.

check out this website for more info
http://www.uvnc.com/docs/uvnc-server/69-ultravncini.html
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now