• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3251
  • Last Modified:

HP 2620 Inter-VLAN Communication

Hi all.  I am having an issue with a set of HP switches, involving two vlans not being able to communicate.  I'm guessing there is some issue with port tagging because these vlans are all on the same subnet.  Another idea is that I should be able to assign an IP to vlan 10, and then 'ip routing' should handle the routing between vlans automatically, but again the problem with that is that the vlans are on the same subnet so I can't assign another 10.1.0.0/16 address on that other vlan.

The whole point of my setup is that I have two different DHCP servers which need to service the devices on vlan 1 or vlan 10, and I need those broadcast domains isolated.  However, the vlans should still be able to talk to each other.  The ports that I have untagged in vlan 10 are ones that the phone system (which provides DHCP to vlan 10) are connected.

This is the config for the switch that has the phone system plugged in:
; J9625A Configuration Editor; Created on release #RA.15.05.0006
; Ver #01:01:00

hostname "FLOOR4-MDF-0"
time timezone -300
no stack
interface 2
   speed-duplex 100-full
exit
ip default-gateway 10.1.4.1
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-20,25-28
   ip address 10.1.5.40 255.255.0.0
   no untagged 21-24
   exit
vlan 10
   name "Voice"
   untagged 21-24
   tagged 1-20,25-28
   voice
   no ip address
   exit
qos type-of-service diff-services
snmp-server community "public" unrestricted
management-vlan 1
no dhcp config-file-update
password manager

Open in new window


This is the config for other switches:
; J9625A Configuration Editor; Created on release #RA.15.05.0006
; Ver #01:01:00

hostname "FLOOR4-MDF-0" 
time timezone -300 
no stack 
ip default-gateway 10.1.4.1 
ip routing 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged 1-28 
   ip address 10.1.5.40 255.255.0.0 
   exit 
vlan 10 
   name "Voice" 
   tagged 1-28 
   voice 
   no ip address 
   exit 
qos type-of-service diff-services 
snmp-server community "public" unrestricted
management-vlan 1
no dhcp config-file-update
password manager

Open in new window


Any suggestions would be greatly appreciated.
0
ClearBlueTechnologies
Asked:
ClearBlueTechnologies
  • 2
1 Solution
 
jburgaardCommented:
'...need those broadcast domains isolated...'
then you must have more than one network

The 'management-vlan 1' statement will disable the vlan1 from participating in routing.
so in CLI config:
 no management-vlan 1

-by the way 'ip address 10.1.5.40 255.255.0.0' can only be on one switch  
and I asume you also only want one L3-enabeled switch, so only one switch with  'ip routing'

On the L3 switch you should have
an IP address in vlan 1
and another IP in vlan 10 in a differen network
these 2 IP's should be DefaultGateway of clints in respective vlans

HTH
0
 
FideliusCommented:
Hello,

Unfortunately, there is no way to make it work. In your case, two VLANs with same subnet can't communicate between themselves as routing is not possible. Bridging is also not an option because your need to separate broadcast domains because of DHCP.

One other thing which renders this situation unpossible is that two different devices each in one VLAN can get same IP address from their respective DHCP server, so switch will be very confused.

Picture situation you and me having same cell number, and you are trying to call me using your own cell phone number. There is no way it can work.

Hope you get my point!
Regards!
0
 
jburgaardCommented:
Why is it not possible to set up different networks.
Why cannot the one be changed and why not the other??
0
 
ClearBlueTechnologiesAuthor Commented:
We re-numbered the other "voice" vlan and added the necessary routing and all is good.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now