?
Solved

voice vlan configs on Cisco Catalyst

Posted on 2012-08-24
7
Medium Priority
?
867 Views
Last Modified: 2012-09-08
This is what I have:
router <--> switch 3560X <-->avaya phone <--> PC

I am configuring the 3560X for the voice vlan. the PBX connected to the switch is doing the dhco service for the phones and a remote server will do the dhcp for the data.

vlan 2 (data) - vlan 3 (voice) - vlan 4 (management)

My question is what is the difference between config 1 & config 2 as far as the voice is concern and which one is the best practice config (see below).

config 1:
interface gig0/2
switchport access vlan 2
switchport mode access
switchport access vlan voice 3

config 2:
interface gig0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
switch trunk native vlan 2
spanning-tree portfast trunk

Thx
0
Comment
Question by:biggynet
  • 4
  • 2
7 Comments
 
LVL 10

Expert Comment

by:djcanter
ID: 38330461
An access port allows only 1 vlan.
The first config allows only vlan2 traffic on the switch port.

The second is a trunk which will allow vlan2/3 with vlan 2 being native.
If you are connecting the pcs to the phones you will need to use config2.
0
 

Author Comment

by:biggynet
ID: 38331502
"If you are connecting the pcs to the phones you will need to use config2. " I have to disagree with it  because I have 2 vlans within my interface and vlan 2 is for the PC connected to the phone which will be on vlan3.
0
 
LVL 10

Expert Comment

by:djcanter
ID: 38331644
0
Sign your company up to try the MB 660 headset now

Take control and stay focused in noisy open office environments with the MB 660. By reducing background noise, you can revitalize your office and improve concentration.

 

Author Comment

by:biggynet
ID: 38331734
from  my understanding, in config 1, it is actually a trunk between the switch and the VoIP phone. The PC will be tagged with vlan 2 and the voice will be tagged with vlan 3. Config 1 is actually implemented in my network and it it working.
I just discovered config 2 so that is why I am just wondering which one is the best practice.
0
 
LVL 10

Expert Comment

by:djcanter
ID: 38331746
It may be that your switch is passing dot1q frames on the access port and the phone is removing the tag and passing the traffic to the pc.

To answer your question as to best practice. You should use config 2.
0
 
LVL 8

Accepted Solution

by:
hus1984 earned 1400 total points
ID: 38332228
config 1 id the correct configuration to connect IP Phone to the catalyst switch:
int g0/0
switchport mode access
switchport access vlan 2
switchport voice vlan 3
spanningtree portfast

voice vlan is a feature that allow you to configure your port as an access port with 2 vlans one for data and the other is for voice.

Thanks
0
 
LVL 10

Assisted Solution

by:djcanter
djcanter earned 600 total points
ID: 38332384
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Almost all Internet protocol telephones have built-in switches at the back that allow you to connect your personal computer to one port and use the other port to connect your phone to to a Cisco switch.   Why we need to connect the PC to the pho…
Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question