Only PS/2 keyboard is working, USB doesn't (Xorg.conf)

I have a linux system here which for some reason does not allow USB keyboard input when I'm running the X windowing environment. A ps/2 keyboard works properly, but the USB keyboard is ignored.

There is no desktop environment (e.g. Gnome, KDE etc.), it's JUST a raw X-window environment that runs a single GUI application.

I believe that the system was configured intentionally to behave this way. It's a debian-based custom distro.

Is there an obvious way I can re-enable USB keyboard input? The Xorg.conf is below:

# XF86Config-4 (XFree86 X server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "Files"
#       FontPath        "unix/:7100"                    # local font server
        # if the local font server has problems, we can fall back on these
#       FontPath        "/usr/lib/X11/fonts/Type1"
#       FontPath        "/usr/lib/X11/fonts/CID"
#       FontPath        "/usr/lib/X11/fonts/Speedo"
        FontPath        "/usr/lib/X11/fonts/misc"
#       FontPath        "/usr/lib/X11/fonts/cyrillic"
#       FontPath        "/usr/lib/X11/fonts/100dpi"
#       FontPath        "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
        #Load   "GLcore"
        #Load   "bitmap"
        #Load   "dbe"
        #Load   "ddc"
        #Load   "dri"
        #Load   "extmod"
        #Load   "freetype"
        Load    "glx"
        Load    "int10"
        #Load   "record"
        #Load   "speedo"
        #Load   "type1"
        #Load   "vbe"
EndSection

Section "ServerFlags"
        Option "DontZap" "true"
        Option "DontZoom" "true"
        Option "DontVTSwitch" "true"
        Option "LogFile" "/tmp/XFree86.log"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbDisable"
#       Option          "XkbRules"      "xfree86"
#       Option          "XkbModel"      "pc104"
#       Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "void"
        Option          "CorePointer"
EndSection

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "nvidia"
        Option          "NoLogo"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"

        HorizSync       28-93.75
        VertRefresh     50-60
#       Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Open in new window

LVL 31
Frosty555Asked:
Who is Participating?
 
Frosty555Connect With a Mentor Author Commented:
Okay I figured it out.

In the "InputDevices" section there's a line:

Option          "XkbDisable"

Comment that out, and everything works.
0
 
Dave BaldwinFixer of ProblemsCommented:
Does a USB mouse work?
0
 
Frosty555Author Commented:
I'm not sure... the system only shows a mouse cursor at the very beginning of it's boot when the X window environment is first loading. Once the machine is fully booted and software is running (it's a fullscreen video game that runs automatically on boot) there is no obvious indication of the mouse, no mouse cursor present, so it's hard to test.

I think it's the same as the keyboard - PS/2 probably works, but USB does not.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
Dave BaldwinFixer of ProblemsCommented:
Does the USB keyboard work in the BIOS setup?  If not, you're probably out of luck.
0
 
Frosty555Author Commented:
USB keyboard *does* work in the BIOS. It also works when booting from a live-cd.

Actually, doing a bit more testing the USB keyboard appears to work right up until the X environment runs. I can hit CTRL+C or ENTER during the bootup process and I can see those keystrokes are being read while all the text is scrolling up the screen during bootup.

This is why I suspect it was intentionally configured this way - this linux machine is actually a public kiosk - it's inside a locked cabinet with no keyboard attached. The USB keyboard is probably disabled so that people can't mess around with the machine. (there are usb ports on the front of the kiosk so people can plug in flash drives. The original authors probably didn't want people putting keyboards in)
0
 
Dave BaldwinFixer of ProblemsCommented:
Sounds like you're probably right.
0
 
Dave BaldwinFixer of ProblemsCommented:
Ok, glad you found it.
0
 
Frosty555Author Commented:
found my own solution. it was staring me right in the face
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.