• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7037
  • Last Modified:

Cannot ping outside interface of Cisco ASA

From the outside/Internet, I need to be able to ping the outside interface of a Cisco ASA 5510 running 8.4(3).  I have run icmp permit for the outside Interface but it still won't work.  I see the ping coming in from the outside but get no reply.  In the log from the pinging address I see the following two back-to-back and nothing else regarding the ping:

1. an ICMP session was established in the fast-path when stateful ICMP was enabled using the inspect icmp command.
2. an ICMP session is removed in the fast-path when stateful ICMP is enabled using the inspect icmp command.

I am able to ping to hosts on the inside... but I need the outside interface.

Here is my config:

Result of the command: "show running"

: Saved
:
ASA Version 8.4(3)
!
hostname
domain-name
names
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address xxxxxxxxxxxxxxxx
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address xxxxxxxxxxxxxxxxxxxxx
!
interface Ethernet0/2
 nameif dmz
 security-level 50
 ip address xxxxxxxxxxxxxxxxxxxxx
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address xxxxxxxxxxxxxxxxxxxxxx
 management-only
!
boot system disk0:/asa843-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
 domain-name
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_cryptomap extended permit ip 10.10.100.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list inside_access_in extended permit ip 10.10.100.0 255.255.255.0 any
access-list dmz_access_in extended deny ip 192.168.100.0 255.255.255.0 10.10.100.0 255.255.255.0
access-list dmz_access_in extended permit ip 192.168.100.0 255.255.255.0 any
access-list outside_access_in extended permit tcp any object 10.10.100.10 object-group rdp
bject-group DM_INLINE_TCP_2
!
tcp-map icmp-monitoring
  reserved-bits clear
  synack-data allow
  invalid-ack allow
  seq-past-window allow
  tcp-options selective-ack clear
  tcp-options timestamp clear
  tcp-options window-scale clear
!
pager lines 24
logging enable
logging asdm debugging
mtu outside 1500
mtu inside 1500
mtu dmz 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
asdm image disk0:/asdm-647.bin
asdm history enable
arp timeout 14400
nat (inside,outside) source static 10.10.100.10 xxxxxxxxxxxxxx
nat (inside,outside) source dynamic any interface
nat (dmz,outside) source static 192.168.100.6 xxxxxxxxxxxxxx
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 xxxxxxxxxxxxx 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.10.100.0 255.255.255.0 inside
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 1
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
ssh timeout 5
console timeout 0
dhcpd ping_timeout 750
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics host
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 10.10.100.10 source inside prefer
webvpn
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect xdmcp
  inspect dns
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect http
  inspect ils
  inspect ip-options
  inspect ipsec-pass-thru
  inspect netbios
  inspect pptp
  inspect rsh
  inspect rtsp
  inspect sip  
  inspect skinny  
  inspect snmp
  inspect waas
policy-map localpolicy1
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum client auto
  message-length maximum 512
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:cb121b76b671334afa2a2f6b96e03af4
: end
0
ctxman
Asked:
ctxman
  • 3
1 Solution
 
lruiz52Commented:
try adding

access-list outside_access_in extended permit icmp "IP Pinging From" 255.255.255.255 "outside IP" 255.255.255.255 echo

access-list outside_access_in extended permit icmp "IP Pinging From" 255.255.255.255 "outside IP" 255.255.255.255 echo-reply
0
 
ctxmanAuthor Commented:
Added but the same result.  Logging shows a ping from my outside workstation to the outside interface of the ASA but I get no response.  Logging shows:

1. an ICMP session was established in the fast-path when stateful ICMP was enabled using the inspect icmp command.
2. an ICMP session is removed in the fast-path when stateful ICMP is enabled using the inspect icmp command.
0
 
ctxmanAuthor Commented:
Updated Running:

Result of the command: "show running"

: Saved
:
ASA Version 8.4(3)
!
hostname xxxxxxxxxx
domain-name xxxxxxxxxx
names
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address xxxxxxxxxx 255.255.255.252
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 10.10.100.1 255.255.255.0
!
interface Ethernet0/2
 nameif dmz
 security-level 50
 ip address 192.168.100.1 255.255.255.0
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
boot system disk0:/asa843-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
 domain-name xxxxxxxxxx
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_cryptomap extended permit ip 10.10.100.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list inside_access_in extended permit ip 10.10.100.0 255.255.255.0 any
access-list dmz_access_in extended deny ip 192.168.100.0 255.255.255.0 10.10.100.0 255.255.255.0
access-list dmz_access_in extended permit ip 192.168.100.0 255.255.255.0 any
access-list outside_access_in extended permit tcp any object 10.10.100.10 object-group rdp
access-list outside_access_in extended permit tcp any object-group xenapp-cag-outside object-group DM_INLINE_TCP_2
access-list outside_access_in extended permit icmp host xxxxxxxxxx host xxxxxxxxxx echo
access-list outside_access_in extended permit icmp host xxxxxxxxxx host xxxxxxxxxx echo-reply
!
tcp-map icmp-monitoring
  reserved-bits clear
  synack-data allow
  invalid-ack allow
  seq-past-window allow
  tcp-options selective-ack clear
  tcp-options timestamp clear
  tcp-options window-scale clear
!
pager lines 24
logging enable
logging asdm debugging
mtu outside 1500
mtu inside 1500
mtu dmz 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
asdm image disk0:/asdm-647.bin
asdm history enable
arp timeout 14400
nat (inside,outside) source static xxxxxxxxxx xxxxxxxxxx
nat (inside,outside) source dynamic any interface
nat (dmz,outside) source static 192.168.100.6 xxxxxxxxxx
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 xxxxxxxxxx 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.10.100.12 255.255.255.0 inside
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 1
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 10.10.100.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd ping_timeout 750
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics host
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server xxxxxxxxxx source inside prefer
webvpn
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect xdmcp
  inspect dns
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect http
  inspect ils
  inspect ip-options
  inspect ipsec-pass-thru
  inspect netbios
  inspect pptp
  inspect rsh
  inspect rtsp
  inspect sip  
  inspect skinny  
  inspect snmp
  inspect waas
  inspect icmp
policy-map localpolicy1
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum client auto
  message-length maximum 512
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:ba4f67604adcbe26c94d0eb94fde34f3
: end
0
 
ctxmanAuthor Commented:
This information is valid.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now