Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

EtherChannel set up on two Cisco 3560 Series switches

Posted on 2012-08-24
5
Medium Priority
?
1,054 Views
Last Modified: 2012-12-18
I am trying to setup EtherChannel on two Cisco switches using the Cisco Network Assistant, but it isn't working.

I have two gigabit fiber links going between the switches
I am following the directions found here:
http://www.cisco.com/public/technotes/smbsa/en/us/lan/config_etherchannel_cna.html


When I get to step 5d where I am supposed to check the box for each port that I want to be a group member they won't check. I can click on them but none of them will become checked. I have tried every option for the Load Balance thinking the switches might not support some of the ones present, but that doesn't make a difference.


What is keeping me from being able to create this?

Switch Info
Switch4 = 3560G-24TS (ports Gi0/25 & Gi0/27)
Software version: 12.2(35)SE5-IP-Base

Switch7 = 3560X-48P (ports Gi1/1 & Gi1/2)
Software version: 12.2(55)SE3-universalk9

See attached file for a screen shot
Screen Shot of CNA
0
Comment
Question by:AmbientIT
  • 3
  • 2
5 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 38332448
What happens when you try it from the CLI?

Can you post the configs from the two switches?
0
 
LVL 2

Author Comment

by:AmbientIT
ID: 38352556
Sorry for the delay in getting back to you. I haven't tried it from the CLI as it looked simple enough to do from the CNA and I would rather do it from there as I am not as comfortable with the CLI.

I have attached two text files with the configs in them.
switch4.txt
switch7.txt
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 38352747
I've never used CNA so I can't be any help there.

That said, there is an inconsistency between the ports.

Switch 4
interface GigabitEthernet0/25
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 900
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/27
 description SW7 - North Bldg
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 900
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree portfast trunk
 spanning-tree link-type point-to-point

Open in new window


Switch 7
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2

Open in new window


One of the primary tasks when creating an etherchannel is that all ports must be configured the same. On switch 4, the ports are trunks. On switch 7, they are not.

So get the configurations of the four ports to be the same. Then try to create the channel.
0
 
LVL 2

Author Comment

by:AmbientIT
ID: 38355070
You are looking at the wrong ports on Switch 7, the correct ones are  Gi1/1 & Gi1/2.  
interface GigabitEthernet1/1
 description SW4 - South Bldg
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 900
 switchport mode trunk
 srr-queue bandwidth share 1 30 35 5
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/2
 description SW4 - South Bldg
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 900
 switchport mode trunk
 srr-queue bandwidth share 1 30 35 5
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos trust
 spanning-tree link-type point-to-point

Open in new window

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 1000 total points
ID: 38355392
Okay.

Go to the switches and issue the following command:

int range g0/25 , g0/27
 channel-group 1 mode on


int range g1/1 , g1/1
 channel-group 1 mode on
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
Powerful tools can do wonders, but only in the right hands.  Nowhere is this more obvious than with the cloud.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month20 days, 23 hours left to enroll

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question