[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1271
  • Last Modified:

Dell Powerconnect 6224 VLAN configuration

Have a new Powerconnect 6224, cannot get the VLAN's to communicate.  What to introduce a couple layer 2 switches but can't get past the first step.  Configured 4 VLAN's (10-40), assigned ip addresses.  Can ping the VLAN address from computers connected to the associated VLANs, cannot ping from the switch to the computers and cannot ping across VLANs.  Here is the config:


console#show run
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.4.1, VxWorks 6.5"
!System Software Version 3.3.4.1
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20,30,40
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3
vlan routing 40 4
exit
stack
member 1 1
exit
ip address 192.168.2.1 255.255.255.0
ip routing
interface vlan 10
routing
ip address 192.168.1.1 255.255.255.240


exit
interface vlan 20
routing
ip address 192.168.1.17 255.255.255.240
exit
interface vlan 30
routing
ip address 192.168.1.33 255.255.255.240
exit
interface vlan 40
routing
ip address 192.168.1.49 255.255.255.240
exit
username "admin" password 72f3724aee573738522448c988ab51c4 level 15 encrypted
!
interface ethernet 1/g1
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10
exit
!


interface ethernet 1/g2
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g3
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10,40
exit
!
interface ethernet 1/g4
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g5
switchport mode general
switchport general pvid 10


switchport general allowed vlan add 10
exit
!
interface ethernet 1/g6
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g7
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g8
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20
exit
!


interface ethernet 1/g9
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g10
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g11
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g12
switchport mode general
switchport general pvid 20


switchport general allowed vlan add 20
exit
!
interface ethernet 1/g13
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
exit
!
interface ethernet 1/g14
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
exit
!
interface ethernet 1/g15
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
exit
!


interface ethernet 1/g16
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
exit
!
interface ethernet 1/g17
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
exit
!
interface ethernet 1/g18
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
exit
!
interface ethernet 1/g19
switchport mode general
switchport general pvid 40


switchport general allowed vlan add 40
exit
!
interface ethernet 1/g20
switchport mode general
switchport general pvid 40
switchport general allowed vlan add 10,40
exit
!
interface ethernet 1/g21
switchport mode general
switchport general pvid 40
switchport general allowed vlan add 40
exit
!
interface ethernet 1/g22
switchport mode general
switchport general pvid 40
switchport general allowed vlan add 40
exit
!


interface ethernet 1/g23
switchport mode general
switchport general pvid 40
switchport general allowed vlan add 40
exit
!
interface ethernet 1/g24
switchport mode general
switchport general pvid 40
switchport general allowed vlan add 40
exit
exit
0
Webcc
Asked:
Webcc
  • 4
  • 3
1 Solution
 
Rick_O_ShayCommented:
I would start by removing the "vlan routing 10 1, vlan routing 20 2, vlan routing 30 3,
vlan routing 40 4" statements which shouldn't be needed and may be confusing things.

I know you aren't to this point yet but you will need a static default route configured to get out to the internet router and if you are using DHCP you will need to configure relay agents/ip helpers.
0
 
Rick_O_ShayCommented:
I forgot to ask if you had made the default gateway of the VLAN connected PCs the interface address for the that VLAN  which you just added.

Like 192.168.1.17 for VLAN 20.
0
 
WebccAuthor Commented:
Yes I did configure the default gw address on the PCs to the associated VLAN address.  Set routing globally.  What commands do you enter to route between VLANs?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Rick_O_ShayCommented:
I don't think there is a command except to have routing enabled and a proper interface configured lik eyou do already.

It sounds like maybe something thinks its network has a wider mask than it actually does. Are the PCs also showing the 255.255.255.240 mask?
0
 
WebccAuthor Commented:
Yes they are.  Found a couple posts that talked about inter-vlan routing and it claimed you can only do it with a trunk port,  is this true?
0
 
Rick_O_ShayCommented:
I  think that would only be a true statement if this was a layer two only switch and you needed a trunk/tagged link to an external router for ip routing.

I wonder if it is the subnetting you are trying to use that is causing the problem. Have you tried to use some unique /24 networks to rule that out?
0
 
WebccAuthor Commented:
Thanks for the help.  Turns out it has something to do with the Windows 7 machines which cannot communicate.  If we go XP can talk across VLANs.  Tried disabling firewalls, even put them on an unmanaged switch still no luck, very weird.  Going to put one of the Win Servers and see if they will access resources off the server.
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now