• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1077
  • Last Modified:

How do I mount a NTFS share in Centos 6.2

Below novice linux guy. Trying to get NTFS share to mount in Centos 6.2 with write permission.
I have CentOS 5.7 working using the following method, can't get it to work in 6.2.
1. On CentOS vm, created user "pusher" set password to "password"
2. On W2K server 2003, created local user "pusher" set password to "password". Set as Administrator
3. On CentOS vm, as pusher I ran mkdir /mnt/SHARE
4. On Centos 5.7 vm, logged in as "pusher", in command line I type mount -t cifs -o username=puser,password=password //server/C$ /mnt/SHARE
5. I can then read and write to /mnt/SHARE

When I try this same thing in 6.2 I get read only. WHen I look at permissions it shows drwx-rx-x.  

Again, barely know what I'm doing. Just trying to copy an existing setup. If you could provide full solution using account names etc, it would be much appreciated.

End goal is to have user "pusher" on linux box able to read/write to mounted NTFS directory. again this is working as above in centos 5.7.

Greatly appreciate any help as I'm tearing what little hair I have left out.
0
adamant40
Asked:
adamant40
1 Solution
 
arnoldCommented:
Try using rw option on the mount command
The share you are mounting appears to be an admin mount.

Drwx what username is reflected as the owner of the /mnt/share?
Run chmod 777 /mnt/share after the mount.
0
 
ThomasMcA2Commented:
The d in drwx means "directory." The rwx means the permissions are read/write/execute for the owner - that's why Arnold asked who is the owner. The rx means it's read/execute for the group that owns the file/directory. Running chmod as Arnold suggests will change it to read/write/execute for everyone.
0
 
adamant40Author Commented:
Thanks for the responses. I tried making those changes but it didn't' have any effect, or I didn't complete the steps correctly. After about 100 fails, I got it working with the following combination in the /etc/fstab and using the mount -a command.

//SERVER/share /mnt/SHARE cifs username=pusher,pasword=password,file_mode=0666,dir_mode=0777 0 0

I am going to have to rebuild this again and will try using the instructions above again to see if I was doing something incorrectly. Thanks.
0
 
arunkeerthanCommented:
use the below command


mount -t cifs //shareip/sharename -o username=username,password='yourpassword' /your/mountpint
0
 
adamant40Author Commented:
My answer, although guess work, provided a working solution to my problem. Linux system can now write files into mounted NTFS directory. Could not get experts solutions to work, maybe implementation issue on my end. Appreciate their input as I learned something.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now