• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 294
  • Last Modified:

Windows 2008 R2 Remote Desktop Services node not found and RDP sound quality terrible.

Acquired a SuperMicro with WIndows Server 2008 R2 Enterprise SP2 pre-installed from ebay for home network. I'm putting thin clients on my kids desks and giving them a Terminal Server for their school work so I can recover my PC.

 WS 2K8 was bare so I made it a PDC, a TS, a File Server, a Print Server, and Media Streaming Server, and installed an Asus Xonar DG sound card.

Sound is great from the server but of such poor quality in RDP sessions that it's unusable. On the client I added to the default.rdp file audioqualitymode:i:2. It's still terrible. Looking around the Internet I found instructions to set the Audio Quality = High in the Group Policy Node Remote Desktop Services. Here's the problem. Everywhere I look it says the WS 2003 Terminal Services is replaced by Remote Desktop Services in WS 2008. However, in my Group Policy nowhere is there a RDS node. There IS a Terminal Services node but the only setting for Audio is to enable redirection or not. There is no quality setting. Anybody know why this install of 2008 doesn't look like what the documentation says it should and how to fix it?
0
mraineynola
Asked:
mraineynola
  • 2
  • 2
1 Solution
 
NetfloCommented:
Run the best practise analysers for the roles in server manager.
Have you installed the correct server drivers as per the vendors site?
Have you tested RDP connectivity via a normal desktop PC or laptop. RDP sound redirection over a LAN and WAN should be perfect.
0
 
thinclientguyCommented:
What type of thin client and what type of OS is it using?  Many thin clients themselves have settings for how the sound should be transferred.  Also are you using analog speakers/headset  or a USB headset or USB speakers on your thin client.
0
 
mraineynolaAuthor Commented:
Using a Xonar sound card with Windows 7 64 bit driver. Sound on the WinServ2008 is great. Have tried both the DevonIT thin client and my Vista Business PC. Thin client has USB (connected to powered hub) and PC has Lantec powered speakers. Both have terrible sound. I don't think speakers are the issue, but I will try it with headphones. Sorry, I've been tied up with Hurricane Isaac for a few days and did not have power at home for 5 days.

I am still mystified why Win2008 doesn't look like all of the documetation says it should. I should not see Terminal Services in Group Policy, I should see Remote Desktop Services.
0
 
NetfloCommented:
The naming conventions have changed following the R2 release:

Windows Server 2008 = Terminal Services
Windows Server 2008 R2 = Remote Desktop Services
0
 
mraineynolaAuthor Commented:
Sadly had to conclude that audio over RDP on 2008 Server is just not workable, need to upgrade to at least R2, Server 2012 even better.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now