[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Must be a domain admin to connect to a terminal server

Posted on 2012-08-26
7
Medium Priority
?
844 Views
Last Modified: 2012-08-26
I am adding a new terminal services user to a Windows Small Business Server 2003R2. The user can only connect to the Terminal Server if he is a member of the domain admins group. Where do I give the user rights to login? I cannot allow a user to be a domain admin.
0
Comment
Question by:Racer1950
  • 4
  • 3
7 Comments
 
LVL 78

Expert Comment

by:Rob Williams
ID: 38334861
They need to be added to the "remote desktop user" group on the terminal server.  We usually create a group in AD called Terminal Server Users, and add this group to the "remote desktop User" group on the terminal server.  You can then add members to this group or add the "Domain Users" group, if all users are to have access.
0
 

Author Comment

by:Racer1950
ID: 38334875
I had already added the user to the remote desktop users group in AD on the DC, but it still did not work. Any ideas.
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 38334884
That will not work, it's a different group. It must be the remote desktop user's group on the terminal server itself, which is a local group, not a domain group.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Racer1950
ID: 38334907
I added the domain user to the terminal servers local remote users group.
0
 
LVL 78

Accepted Solution

by:
Rob Williams earned 2000 total points
ID: 38334915
Did it work?
If not check the terminal server's local group policy (gpedit.msc)  under:
local computer policy | computer configuration | windows settings | security settings | local policies | User rights assignment | allow logon through remote desktop services and verify the remote desktop users group is present.

I am assuming you have a separate terminal server and you are not referring to accessing the small business server through remote desktop.  SBS only allows remote access for admin purposes.
0
 

Author Comment

by:Racer1950
ID: 38334937
Bravo! It worked. The user needed to be added to the group policy.
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 38334949
The group is supposed to be there by default but sometimes missing.
Glad to hear you were able to resolve.
Cheers!
--Rob
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
Local Printing Using Remote Desktop Windows 7 sometimes has issues with printing to a local printer using a Remote Desktop Connection (RDC). The 1st step is to verify that printers are checked on the Local Resources tab of the Remote Desktop C…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Loops Section Overview

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question