• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 410
  • Last Modified:

DB Mirroring Error

Hi Team,
I am trying to setup DB Mirroring in our setup and Need your help here!

I've 3 servers (2 (Principal and witness) of them are in one machine and 1 (Mirror) is in other machine) setup ... Firewalls are turned off on all 3 of them.... I want to set them up as Principle, mirror and witness respectively.... Before configuring the mirroring, I backed up the database on Principal and restored it on Mirror database (Restore With No Recovery) . I did it first for the DB backup file and then the transaction log file.......
Now, when I configure mirroring on my my principle server and after choosing my respective serves are principle, mirror and witness.When I am trying to start mirroring I am receiving the below error,

TITLE: Database Properties
------------------------------
An error occurred while starting mirroring.
------------------------------
ADDITIONAL INFORMATION:
Alter failed for Database 'COSBCS_TEST_4GL'.  (Microsoft.SqlServer.Smo)
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=11.0.2100.60+((SQL11_RTM).120210-1846+)&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Alter+Database&LinkId=20476
------------------------------
An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)
------------------------------
The server network address "TCP://ADMIN036.cos2000.cos.net.au:5023" cannot be reached or does not exist. Check the network address name and that the ports for the local and remote endpoints are operational. (Microsoft SQL Server, Error: 1418)
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&ProdVer=11.00.2100&EvtSrc=MSSQLServer&EvtID=1418&LinkId=20476
------------------------------
BUTTONS:
OK

Can you let me know how to fix this error?

Thanks,
Sarvan.N
error-01.jpg
0
COS_IT_AU
Asked:
COS_IT_AU
1 Solution
 
x-menIT super heroCommented:
are you able to connect SSMS to ADMIN036.cos2000.cos.net.au:5023 ?

DB Mirror uses ¿      7022 TCP port, check if is open.

are you sure there are no "real" (not windows firewall) firewalls between servers?
0
 
VIVEKANANDHAN_PERIASAMYCommented:
1.type firewall.cpl in the run.
Turn off the firewall if it's opened.

2. Both principal and secondary SQL server agent should run under same user account.
It shouldn't be local.

I feel most probably second type will fix your issue.
0
 
Ramesh Babu VavillaCommented:
check my blog for simple steps for Database mirroring in Simple Steps

http://sqlservr.blog.com/2011/12/29/database-mirroring-in-simple-steps/


all the SQL Services are started with the same service account, check for login credentails and permissions
try to do

alter database dbname set partner ='TCP://ADMIN036.cos2000.cos.net.au:5023'

check the state of the Mirroring End Points

select * from sys.endpoints

if the endpoints state is stopped , try to start the endpoints
0
 
COS_IT_AUAuthor Commented:
Hi All,

I tried with all the possible solutions to fix the error but I am getting the same error.
Below are the list of tasks/steps i have done to fix this issue,

1) I can able to telnet the mirror database from principal server with 5023 port.
2) I have tried to use the same service account and tried it.
3) Altered the database and checked both the endpoints they are in started mode.

Kindly let me know any possible ways to fix this issue.

Thanks,
Sarvan.N
0
 
Ramesh Babu VavillaCommented:
check my blog
http://sqlservr.blog.com/2011/12/29/database-mirroring-in-simple-steps/


check it i have used IP adress before starting the Database Mirroring
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now