?
Solved

GNS3 Cisco Remote Access VPN Lab

Posted on 2012-08-26
12
Medium Priority
?
1,866 Views
Last Modified: 2012-09-18
I need an expert to help me set up GNS3 lab for Cisco Client/server VPN .

I tried to use the Router and the Cloud on GNS3 but never managed to get the MS Loopback to work properly , I mean the GNS 3 cannot ping internet ...
Is there a work around to set up Cisco VPN Remote access ?

Thanks
0
Comment
Question by:jskfan
  • 6
  • 6
12 Comments
 
LVL 6

Assisted Solution

by:602650528
602650528 earned 2000 total points
ID: 38336486
Linking GNS3 to the loopback adapter would NOT allow you ping the internet since the loopback adpater's ip address would be 127.0.0.1/32 unless you had changed it.

You need to link the GNS3 cloud to your PC's network card and assign an ip address in same subnet as your PC's network, to the router in GNS3. Also assign same gateway in your PC to the GNS3 router. You should be able to ping the PC's IP address, teh default gateway and ultimately the internet e.g 4.2.2.2. If you need to ping a domain name, then you need to config a name-server on your GNS3 router to resolve.
0
 

Author Comment

by:jskfan
ID: 38339562
I have wireless internet connection. Let's say it got this for the ISP:

IP =192.168.1.100
DG=192.168.1.1
DNS=65.65.65.65


So , If I undertsand your statement:
- I will add my wireless adapter to the Cloud in GNS 3
-Configure  router fa0/0 ip address 192.168.1.200  ( fa0/0 is connected to the Cloud)

correct?
0
 
LVL 6

Assisted Solution

by:602650528
602650528 earned 2000 total points
ID: 38339854
Yes
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
LVL 6

Assisted Solution

by:602650528
602650528 earned 2000 total points
ID: 38339862
Do not forget to configure default route and name severs the router though.

ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip name-server 65.65.65.65
0
 

Author Comment

by:jskfan
ID: 38357300
 
Router#sh run
Building configuration...

Current configuration : 618 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.200 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router#
 

Open in new window


C:\>ipconfig

Windows IP Configuration


Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 192.168.1.109
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
0
 

Author Comment

by:jskfan
ID: 38357303
I still cannot ping from the router to the DG 192.168.1.1
even after I changed ip route 0.0.0.0 0.0.0.0 192.168.1.109 it did not ping.
but I can ping from my pc to 192.168.1.200 which is fa0/0 ip address.
0
 
LVL 6

Expert Comment

by:602650528
ID: 38357364
Sorry that doesn't obviously work for wireless though it works for wired NIC card.

Use the method below; I just used it and it worked for me.

STEP 1

Set up a Loopback adapter on your PC.  Do not configure any IP on it. Just leave it as it is.

STEP 2

The next phase is to bridge the Loopback adapter with your wireless adapter. This is the key to making it all work.

a. Open your Network Connections
b. Use the <Ctrl> to select both the Loopback adapter you just created and your wireless adapter.
c. Right Click and the select Bridge Connections. Windows will then set up a new adapter called Network Bridge (MAC Bridge Miniport). All of the IP settings for your wireless adapter will now show up under the Network Bridge.
d. Once Windows has finished doing its thing, you are ready to connect to the real world using the wireless adapter.

STEP 3

On GNS3 cloud in the option to choose your network adapter, choose the Loopback adapter you created. Be sure to give the interface on the router that connects to your cloud an IP address that is on the same subnet as your wireless network.

This works as I just tested it before sending you this now.
0
 

Author Comment

by:jskfan
ID: 38357831
I bridged the Loopback with the wireless adapter, but in the cloud I don't see the Loopback adapter in the drop down arrow...I see just the wireless adapter.
0
 
LVL 6

Expert Comment

by:602650528
ID: 38357897
What version of GNS3 do u have? Verson 3.0.73 does not show the loopback in the cloud. You need the latest version of GNS3 version 3.0.83.
0
 

Author Comment

by:jskfan
ID: 38359377
I downloaded GNS3 version 3.0.83 I can see the MS loop back now in the cloud, so I selected.
But I still cannot ping neither the ip address of the wireless adapter nor the DG.
here is the config

C:\>ipconfig

Windows IP Configuration


Ethernet adapter Network Bridge:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::4059:505c:9a1a:181c%37
   IPv4 Address. . . . . . . . . . . : 192.168.1.110
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

Open in new window


Router#sh run
Building configuration...

Current configuration : 618 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.200 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router#

Open in new window

0
 
LVL 6

Accepted Solution

by:
602650528 earned 2000 total points
ID: 38360987
Can you confirm the following please:

1. What Windows OS are you using ?
2. After bridging, from your PC, are you able to ping the bridge adapter ip (192.168.1.110), the default GW  (192.168.1.1) and internet (4.2.2.2). If you are not able to, please reboot your PC after bridging and try again.
4. If you are able to ping from your PC, try the ping from GNS3
0
 

Author Closing Comment

by:jskfan
ID: 38408848
thanks
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
In a question here at Experts Exchange, a member was looking for "a little app that would allow sound to be turned OFF and ON by simply clicking on an icon in the system tray". This article shows how to achieve that, as well as providing the same OF…
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

589 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question