[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6699
  • Last Modified:

Tomcat crashes - Maximum number of threads (200) created for connector with address null and port 8500

Gurus,

I'm experiencing several Tomcat 6 crashes because the maximum number of threads is being exceeded.

Error: Maximum number of threads (200) created for connector with address null and port 8500

However, I have this set to 1024.

 
    <!--The connectors can use a shared executor, you can define one or more nam
ed thread pools-->
    <!--
    <Executor name="tomcatThreadPool" namePrefix="catalina-exec-"
        maxThreads="1024" minSpareThreads="4"/>

What am I missing here?
0
xbox360dp
Asked:
xbox360dp
  • 5
  • 3
1 Solution
 
CEHJCommented:
Make sure you haven't more than one Tomcat instance running
0
 
xbox360dpAuthor Commented:
I have 3 other tomcat instances running.

Why would this be a problem?
0
 
CEHJCommented:
Because the message you're getting might not be from the instance you think

Moreover, if you have no fewer than 3 running on the same box, the OS might not be able to cope with the number of threads
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
xbox360dpAuthor Commented:
Interesting ...

There is no way around me having multiple tomcat instances on the same server. What would you recommend?
0
 
CEHJCommented:
What OS is it?
0
 
xbox360dpAuthor Commented:
Oracle Solaris 10 64bit
0
 
CEHJCommented:
Don't know that flavour, but if my comments are along the right lines, you could start looking into max file handles, max processes, user quotas etc.
0
 
ariohCommented:
are you sure than lines from server.xml you posted are not commented?
as I see they are commented, so there may be no Executor at all

   <!--  comment starts here
    <Executor name="tomcatThreadPool" namePrefix="catalina-exec-"
        maxThreads="1024" minSpareThreads="4"/>

there is also "maxThreads" parameter, that you can set on "Connector"
see http://tomcat.apache.org/tomcat-6.0-doc/config/http.html
0
 
CEHJCommented:
What was the problem?
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now