Can't See Oracle DB Tables using Oracle SQL Developer

Posted on 2012-08-27
Last Modified: 2012-08-27
Hello, I'm using Oracle SQL Developer to view some Tables. I have verified by connection information is accurate however when I try to open/view the Tables there are none. My vendor tells me it should work... When I hover over the Tables in the tree I see the following message/error:

Question by:intoxicated_curveball
    LVL 23

    Expert Comment

    I've scratched my head over the more recent iterations of this lovely but free product.  What you are seeing is the default filter, meaning, 'don't show me my recycle-bin (trashed) tables.

    1.  In the worksheet, are you able to confirm the tables with a simple "SELECT tablename from sys.user_tables;" ? To view any tables in your own schema.
    2.  You may already know that newcomers to the tool expand the highest "tables" and expect to view everyone's tables.  Rather, we all learn to expand "Other Users" instead.  Does that come into play here?
    LVL 20

    Expert Comment

    Which version of SQL Dev are you using? If you expand your connection folder you should see something like "Tables (Filtered)" - right click on that and select Clear Filter. That should give you a full list of tables in that schema.

    ETA: I believe dvz got it, his 2nd point is most likely your issue.

    Author Comment

    Hi Dvz, this is my first time using Oracle DB or Oracle SQL Developer. So I'm not supposed to expand the root Table then? I don't see my username in "Other Users"?? To be honest only the "Other Users" item has anything in it... shows hundreds of usernames or something but don't see mine.

    Btw I've tried both versions and

    Gatorvip I tried Clear Filter but didn't help.
    LVL 23

    Accepted Solution

    1. There are many, many, many sources on how to use the tool.  Don't let yourself get overwhelmed.  The built-in Help topics aren't all that bad.

    2.  Yes, as a developer tool the assumption is that one works on one's own objects primarily.  Thus, the "Other Users" is exactly that.

    3.  There is a options setting, as I recall, that toggles the display (of other users) to include or exclude those user accounts that do not own objects.  That's useful for a database where there may be thousands of user accounts but only a handful of one owning data.

    4.  To your original point, you want to see table names....  get to a SQL prompt and simply execute the following to see all the tables to which your account has some kind of privilege (usually SELECT) (note, excluding the SYS-related objects).  That might help.

    select owner, table_name from all_tables where owner not like '%SYS%'
    order by 1,2

    Featured Post

    Gigs: Get Your Project Delivered by an Expert

    Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

    Join & Write a Comment

    Note: this article covers simple compression. Oracle introduced in version 11g release 2 a new feature called Advanced Compression which is not covered here. General principle of Oracle compression Oracle compression is a way of reducing the d…
    Using SQL Scripts we can save all the SQL queries as files that we use very frequently on our database later point of time. This is one of the feature present under SQL Workshop in Oracle Application Express.
    Via a live example, show how to take different types of Oracle backups using RMAN.
    This video shows how to copy an entire tablespace from one database to another database using Transportable Tablespace functionality.

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now