Toshiba Satellite L655 will not power on

I have a toshiba satellite l655 that the power dongle was broken because the power cable got yanked out of the hole and it broke the plastic inside. The laptop ran until the battery ran down. I purchased a new cable and installed it but the laptop will not power on. I get no power light to signify it is plugged in or a battery charging light. Thinking that it was probably the motherboard got shorted during the whole ordeal, I purchased a new MB. I replaced the MB and still the same issue. I have tested the voltage all the way to the MB and it has a solid 19v all the way. I have tried to power it on with only the power adapter plugged in, I have pulled the cmos battery. I have tried the "hold the power button for 30 sec" trick. Everything logically should work but it is just unresponsive. Any ideas???
ACEINCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

web_trackerComputer Service TechnicianCommented:
When the mobo was replaced were all the wires connected properly?, It is strange that you don't get at least a battery charge light, indicating that the battery is charging. I would start by unplugging the keyboard, removing the hard drive, optical drive, the wireless cards, modem and the battery. See if it will power on with out these items, if it does insert them back one at a time, trying to power on system after each item is being replaced until it no longer powers on then the last item could be shorting out your system. If it does not power on after all these items are removed remove the memory. then insert the power adapter and try to power it on see if you get any diag lights lighting up. Always always when removing and inserting components remove the power supply and the battery. You should also be wearing a grounding strap to ensure you are grounded against static discharge.
0
ACEINCAuthor Commented:
Yeah, I already tried all that. All that is hooked up is the power and battery. The only components are the CPU and one stick of RAM. if I remove all the RAM it still does not power on.
0
web_trackerComputer Service TechnicianCommented:
You tried powering on the system with the battery removed, and connected only via the ac adapter right? It could be faulty mobo even though it is new (this is known as Dead on Arival  [DOA]). or it may be a faulty power switch.... but then you should at least see the charging led when the battery is inserted.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

nobusCommented:
0
ACEINCAuthor Commented:
web_tracker: Yes, I tried powering it up with the battery out. I'm beginning to think its DOA also. Just kind of strange that it ran for a while on the battery after the incident but then wouldn't power back on.

nobus: I already have replaced the power dongle. Its not just a jack in this model, it actually is a cable that plugs into the MOBO.
0
CallandorCommented:
If you ran the battery down until it was completely dead, it may have problems recharging.  However, if you removed the battery, the laptop should still work if plugged in to the AC charger.  Perhaps the AC charger was damaged during the incident and can't provide enough current?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ACEINCAuthor Commented:
Tested the charger. Solid 19v output.
0
nobusCommented:
did you test it under load?  if not it can still be bad
you can test the AC adapter on another laptop, or test with another one on yours
0
ACEINCAuthor Commented:
Nobus: Amazing. I have never seen a power adapter that would give a steady precise voltage but die under a load. I tried a different p/a and it booted right up. Even with the old MB! Super job full answer credit!!!
0
CallandorCommented:
Ha! - I was the first to say that the adapter was probably damaged and couldn't provide enough current.
0
nobusCommented:
tx for feedback - i've seen it happen before...
0
CallandorCommented:
I'll recommend a split between http:#a38340900 and http:#a38341989
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.