• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1113
  • Last Modified:

Interconnecting 3Com switches with Cisco

Let's consider two 3com switches (4500 and 2924) and Cisco Catalyst 3750G.

1) How should interconnect 3com switches? Which ports should I use?
When I connect one of 25, 26, 27 or 28 port of 4500 to SFP port of 2924 I get an error: "fabric port is isolated because of connection error".

2) Which port of which switch should I connect to Cisco Catalyst 3750G?

See enclosed photo.
  • 6
  • 4
2 Solutions
You need to set the port to a trunk port which ever one you use. Have you ensured the ports are configured as trunks?
marianheAuthor Commented:
Your answer is applicable for which question?
James HIT DirectorCommented:
Pick a port number:

Configure Trunk on this port using:

switchport trunk encap dot1q
switchport mode trunk
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

marianheAuthor Commented:
No need to configure trunk.
I do not want Cisco VLANs in 3com switches.

To interconnect 3com Baseline 2924 and Cisco 3750G, you just need to use one of 3com SFP ports. It works.
marianheAuthor Commented:
Still first question remains not answered.
You can use which ever SFP port you want as long as you configure it as a trunk port with the same configuration on both switches for interconnecting ports. If you just plug in the cable it is likely the port is configured as an access port with extra configuration expecting a pc/phone or other access device to be plugged in. This causes issues with connectivity between switches.

Trunk has no relation to VLAN. dot1q does and you do not need to configure this unless you want VLANs across your network to pass through the port.

If you have no VALns then this is not applicable but you still need theport to be a trunk port.

If you do run VLANs and you do not enable dot1q then the vlans will not pass through the port.
marianheAuthor Commented:
[4500-GigabitEthernet1/0/27]display interface GigabitEthernet 1/0/27
 GigabitEthernet1/0/27 current state : DOWN
 IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 0016-e023-4b7b
 The Maximum Transmit Unit is 1500
 Media type is twisted pair, loopback not set
 Port hardware type is 1000_BASE_T
 Unknown-speed mode, unknown-duplex mode
 Link speed type is autonegotiation, link duplex type is autonegotiation
 Flow-control is not enabled
 The Maximum Frame Length is 1522
 Broadcast MAX-ratio: 100%
 Unicast MAX-ratio: 100%
 Multicast MAX-ratio: 100%
 PVID: 1
 Priority: trust
 Mdi type: auto
 Port link-type: xrn-fabic
  Tagged   VLAN ID : all
  Untagged VLAN ID : none
 Last 300 seconds input:  0 packets/sec 0 bytes/sec
 Last 300 seconds output:  0 packets/sec 10 bytes/sec
 Input(total):  67 packets, 12480 bytes
	 22 broadcasts, 34 multicasts
 Input(normal):  - packets, - bytes
	 - broadcasts, - multicasts
 Input:  11 input errors, 11 runts, 0 giants,  - throttles, 0 CRC
	 0 frame,  - overruns, 0 aborts, 0 ignored, - parity errors
 Output(total): 47 packets, 7032 bytes
	 0 broadcasts, 47 multicasts, 0 pauses
 Output(normal): - packets, - bytes
	 - broadcasts, - multicasts, - pauses
 Output: 0 output errors,  - underruns, - buffer failures
	 0 aborts, 0 deferred, 0 collisions, 0 late collisions
	 0 lost carrier, - no carrier

[4500-GigabitEthernet1/0/27]port ?
  access            Specify current access port's characteristics
  hybrid            Specify current hybrid port's characteristics
  isolate           Port isolate
  link-aggregation  Link aggregation group
  link-type         Specify port link-type
  trunk             Specify current trunk port's characteristics

[4500-GigabitEthernet1/0/27]port  link-type ?
  access      Access link-type
  hybrid      Hybrid VLAN link-type
  trunk       VLAN trunk link-type
  xrn-fabric  Fabric-port link-type

[4500-GigabitEthernet1/0/27]port  link-type trunk ?

[4500-GigabitEthernet1/0/27]port  link-type trunk 
 Can not configure fabric port!

Open in new window

From what I understand to configure the port to a trunk port if it is configured as a fabric port you need to first configure as an access port and then configure to be a trunk port.

Can you try using the command:

undo port link-type

then do port

link-type trunk

A fabric port is used for stacking.

You may also need a cross over cable if you are using Ethernet to link the 2 switches together.
marianheAuthor Commented:
Only link-type access is needed. No trunk.
Although link-type access will work you will find later down the line you have the inter-connecting ports shutting down because of illigal traffic. This will be because of mis-configuration of port type where you have set the uplink ports to access and not trunk.
marianheAuthor Commented:
My solutions are the best.

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now