Incoming Mail Server Setup

Hi,

As part of an Alfresco setup, I have enabled the incoming mail server. I'm having some issues with the configuration that I hope someone can help me with. I am new the the work of mail servers, so please bear with any stupid questions!

Setup is on a CentOS box hosted by Rackspace.

I have run the following tests. Part of my domain name has been changed to 'example' for the purpose of this post.

My alfresco mail server configuration:
----
email.server.enabled=true
email.server.port=25
email.server.domain=doc.example.co.uk
email.server.connections.max=3
-----

If I telnet the following:
"telnet localhost 25" I get the following message which indicates (to me at least) that the server is up and running.
"220 EXAMPLE-ALFRESCO.localdomain ESMTP Postfix"

However, if I telnet the following:
"telnet doc.example.co.uk 25" from the server then I get the following:
"telnet: connect to address xx.xxx.xxx.xx: Connection refused

I also cannot establish the connection if I telnet the above from my PC over the internet although I can telnet the FTP service running on port 21.

I have created a MX DNS record as follows:

Name: doc.example.co.uk
Content: doc.example.co.uk
Domain Name: example.co.uk
TTL: 300 seconds
Type: MX
(Priority set to 10)

I realise that there are probably multiple places where I could have gone wrong with the setup and configuration, but it would be good if someone can point me in the right direction on how I can solve this connection issue.

Thanks,
joust888Asked:
Who is Participating?
 
smckeown777Commented:
Well that tells me either port 25 is blocked on your router/firewall, or your ISP doesn't allow traffic on port 25 - have you confirmed the settings on the router?

Or...you changed to port 2525 - did you make changes to the router at all? Normally you need to open ports and do the NAT mapping to make these things work...or what type of broadband are you on? 1 public IP? Or a range of public IP's?

CentOS - I assume this is your router? Then yes its probably a setting on that

No, you'll need port 25(as all mail servers worldwide use this by default), so switching this isn't going to help - we need to get port 25 responding to make this work

When you switched to 2525 - what does the netstat output show?
Also when you switched to 2525 - what other changes to your router/firewall did you make?
0
 
smckeown777Commented:
You've created the MX record - have you created a matching A record?

This line
telnet: connect to address xx.xxx.xxx.xx: Connection refused

The xxx part - does the name doc.example.co.uk resolve correctly to the IP that your server is running on?
0
 
joust888Author Commented:
Yes it does. I run an instance of alfresco on the server which I access through doc.example.co.uk:8080/share.

Also, if I do the following:
"telnet doc.example.co.uk 21" I get the following:

"220 FTP Server Ready" (which is the port that the FTP server has been set up)

My thinking is that it could possibly be port 25 that is refusing connections.

If I run NetStat -l I get the following difference between FTP and SMTP, which I think might be a clue?

Local Address:
*:ftp
localhost.smtp

That indicates that it is only listening on the localhost and not anything else. If my assumptions are correct - how would I go about enabling it to listen to the outside?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
smckeown777Commented:
Yep, sounds like it for sure...

Ok I'm not familiar with the mail server you are running, but somewhere in the config section will be an option to either 'listen' on an interface in which case you need to select the correct IP

Or maybe the email domain is not correct?
http://docs.alfresco.com/4.0/topic/com.alfresco.enterprise.doc/concepts/email-intro.html

According to that doc you should have

email.server.domain=example.co.uk

and not

email.server.domain=doc.example.co.uk

like you have?

Sorry I'm not up to speed on that mail server, but yes based on your output from netstat it looks like its not listening to anything other than localhost
0
 
joust888Author Commented:
Having switched the configuration of the Alfresco mail server to port 2525 I can now telnet to the mail server externally by "telnet doc.example.co.uk 2525". I get the "220 doc.example.co.uk ESMTP SubEthaSMTP 3.1.6" message.

Thus, it does not seem to be the mail server setup that is preventing access to port 25. Could it be a CentOS issue that I need to resolve?

Also - is there a way of using port 2525 instead of port 25? Even though I can reach port 2525 via telnet - my mail server still does not seem to receive e-mail when I e-mail to it from an external mail addres such as gmail.
0
 
joust888Author Commented:
I have this working now. I decided to let this lie for a little while as I was making some other major changes to the installation and thought I'd see if the problem fixes itself in some way.

Initially the alfresco mail server was installed on a CentOS  (linux operating system) on rackspace and they allow communication through port 25.

I have since changed the operating system of my server and am now rolling out alfresco on an Ubuntu server. It also seems that the mail server is now working 100% so I am assuming that it is:
1) a CentOS default firewall thing which does not allow comms through port 25 - I assume someone with the same problem could get around it by altering the port settings on the iptables...
2) The only real other difference to the 2 installations was that I had SSL enabled and set up on the CentOS server. I can't really think that that would have been the issue though as the SSL was configured to run through port 8443.

I am about 95% sure that the issues relate to CentOS and the default security settings that comes with it. The question, to answer this question, would therefore be how to open port 25 on a CentOS machine to allow communication from other sources than localhost.

Thanks for all the help.
Jacques
0
 
joust888Author Commented:
I was unable to solve the problem on the CentOS server, but the firewall was set up differently on the UBUNTU box and got around the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.