• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 856
  • Last Modified:

UNC browse by name doesn't work

I am having a strange issue.  When I try to browse a unc path by the name it doesn't work but if I do it by IP it works fine.

\\srv-nas                 <-- doesn't work
vs.
\\192.168.0.100     <-- works fine

I have a windows small business 2003 server and the dns is correctly set for the A record of srv-nas to be resolved to 192.168.0.100. I can ping srv-nas and it replies 192.168.0.100.  I even set an entry in the host file just to be thorough. Of course I've rebooted. I also am not using a WINS.

Plus the \\srv-nas works fine on other machines.

This machine is running windows 7 64bit.
0
jasonslogan
Asked:
jasonslogan
  • 2
1 Solution
 
jmulvey123Commented:
How did you put the entry in the hosts file? Was it a fully-qualified name ("srv-nas.example.com 192.168.0.100") or was it the short name ("srv-nas 192.168.0.100")  ?
If you're going to use short names, you need to ensure the hosts file also has the short name.

Also, can you tell us if srv-nas is in the same DNS domain name as the client?
If not, these kind of issues will plague you until you set up WINS.
0
 
jasonsloganAuthor Commented:
I logged in as a different user and it worked fine.  I logged in with that user to another computer and it worked fine.

I've determined the profile itself on that one computer was the problem.  I deleted the profile and logged in again.

It worked fine after that.
0
 
jasonsloganAuthor Commented:
I wish there was a registry hack or a "fix it" from Microsoft on this but there isn't.  Microsoft says to delete the profile and start over.
0

Featured Post

Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now