[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 762
  • Last Modified:

Windows 7 Sharing of User Folder By Default

Hello,

I have migrated a network to all Windows 7 Pro SP1 32bit and 64bit and discovered each user's folder is being shared out with full permissions.

It is a Peer-2-Peer network with a few computers and two printers (one network and one shared via USB from one of the PC's). Also, Use Sharing Wizard box is checked along with File and Printer Sharing enabled and Network Discovery enabled.  I need all the PCs to be able to access the Public folders on all the PC's, but do not want people to access to that user's folder.

I have checked all the user's folders ("ann" for this example) and none of them are being shared, yet Windows still lists all of them as being shared?  If I disable File and Printer sharing all access goes away, which will not work.

I have attached screenshots to help reference this question and they are based viewed in order.

Thanks
Win7-Sharing.jpg
Win7-Sharing-2.jpg
Win7-Sharing-3.jpg
Win7-Sharing-4.jpg
Win7-Sharing-5.jpg
0
rwhit84
Asked:
rwhit84
1 Solution
 
aindelicatoCommented:
What are the share or advance permissions of the USERS folder, not the ANN folder?
0
 
gbarrientosCommented:
Open elevated command prompt, type: net share
then you can remove the shares by typing:
net share "name of share" /delete
0
 
gbarrientosCommented:
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Run5kCommented:
Keep in mind that when you configure a Windows 7 machine to share the Public folder (as seen below), it actually shares the Users folder since the Public folder resides within it.  However, as long as your NTFS security persmissions are set correctly you don't need to worry about other people accessing Ann's user folders.

Advanced Sharing Settings
0
 
Lionel MMSmall Business IT ConsultantCommented:
Click on Libraries--you should then see all folders for that user. Now right click on each library and you you see if the shared button is checked or not. I also assume you have set your preferences for sharing under
Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings
0
 
rwhit84Author Commented:
Thank you for your help.  It is appreciated!
0
 
Run5kCommented:
Glad to help!
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now