[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1076
  • Last Modified:

Cannot get SVI on ISR G2 to come up

Hello, I have a brand new Cisco 2901 with an 8 port ehwic that I am trying to configure.  I have configured the vlans and the svi's and a dhcp pool for the voice and data vlans.  Each port on the ehwic is configured as an access port with the voice vlan configured as well.  When I do a show int vlan30 (voice vlan) it shows up and up, but when I do a show int vlan10 (data vlan) it shows down and down.  I have had my laptop plugged into gig0/1/0 for days and the vlan still will not come up.  When I do a show vlan-switch, the vlans are there and each port shows up as a member of both voice and data vlans.  Not sure what I am missing here.  Here are the pertinent parts of the config:



Current configuration : 5243 bytes
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 10.3.15.1 10.3.15.99
ip dhcp excluded-address 10.1.105.1 10.1.105.99
!
ip dhcp pool Phones
 network 10.3.15.0 255.255.255.0
 default-router 10.3.15.1
 dns-server ***.***.***.***
 domain-name ***.**
 option 150 ip ***.***.***.***
!
ip dhcp pool Data
 network 10.1.105.0 255.255.255.0
 default-router 10.1.105.1
 domain-name ***.**
 dns-server ***.***.***.***
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description to WAN
 ip address 10.6.0.11 255.255.255.254
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1/0
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/1/1
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/1/2
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/1/3
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/1/4
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/1/5
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/1/6
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/1/7
 switchport access vlan 10
 switchport voice vlan 30
 no ip address
 spanning-tree portfast
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 10.1.105.1 255.255.255.0
!
interface Vlan30
 ip address 10.3.15.1 255.255.255.0
!
!
!
router eigrp 1001
 network 10.0.0.0
 eigrp stub connected summary
!
ip forward-protocol nd
!
0
geekusa
Asked:
geekusa
1 Solution
 
geekusaAuthor Commented:
I was on IOS 15.1.4 and I upgraded to 15.2.4.  Turns out it is a bug with the ehwic module and turning on portfast with a voice vlan.  I got my configuration to work without portfast and then upgraded and it worked with portfast configured on the switchports.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now