• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 570
  • Last Modified:

CAnt ping from my switch to connected router

I am not sure why, but I can not ping from inside my switch to the connected router.

Switch:

interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 no ip address
 ip helper-address 192.168.1.150
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN100
 description Voice_Vlan_Bldg1
 ip address 192.168.1.251 255.255.255.0
 ip helper-address 192.168.1.150
 no ip directed-broadcast
 no ip route-cache


interface Ethernet0/0
 ip address 192.168.1.252 255.255.255.0
 no ip directed-broadcast

A straight thru cable connects f0/48 on switch to e0/0 on router.
0
jbell72
Asked:
jbell72
  • 9
  • 5
  • 3
1 Solution
 
airborne1128Commented:
Can you show us the config for your router?
0
 
mmichaCommented:
You need to setup the router side to do trunking as well, or remove the trunking from the switch side.

Take a look at:

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/336-cisco-router-8021q-router-stick.html
0
 
jbell72Author Commented:
basic router:
interface Ethernet0/0
 ip address 192.168.1.252 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/0.1
 encapsulation dot1Q 100
 ip address 10.0.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/0.2
 no ip directed-broadcast
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
airborne1128Commented:
Thas your problem.  Trunking is setup on your switch, but not your router.
0
 
jbell72Author Commented:
removed trunkport from switch, still nothing.
0
 
airborne1128Commented:
Are you trying to ping the ip of E 0/0 on your router?
0
 
airborne1128Commented:
How is port 48 configured now?
0
 
jbell72Author Commented:
yes, and e0/0.1. Attempting from inside of my switch consoled in.
0
 
mmichaCommented:
I'd try setting a default gateway on your switch to point to the router and see what happens...
0
 
jbell72Author Commented:
interface FastEthernet0/47

And nothing follows.....
0
 
mmichaCommented:
You probably also want to setup the management VLAN on the switch, along with the default gateway.
0
 
airborne1128Commented:
Try setting like this...

Interface Gi0/48
switchport access vlan 3
switch port mode access
no shut

On the router...

Interface gi0/0.3
encapsulation dot1q 3
ip address 192.168.1.252 255.255.255.0
no shut
0
 
jbell72Author Commented:
management vlan is vlan 100, nevermind the description.
0
 
jbell72Author Commented:
nope, tried all fo what was  just said separately.
0
 
jbell72Author Commented:
wait! Something worked!
0
 
jbell72Author Commented:
I removed gw command and it still works. SO what worked was putting port 48 in access vlan 100? I know it works right now, but is that right? It should be a trunk port. My goal is to get vlan 10 working on the router to use as a voice vlan and gw of 10.0.1.1 since my switch is layer 2. I have a phone plugged into f0/1.

interface Ethernet0/0.1
 encapsulation dot1Q 10
 ip address 10.0.1.1 255.255.255.0
 no ip directed-broadcast
0
 
jbell72Author Commented:
So I can ping back and fourth from router to switch, I can even  ping from 10.0.1.1 to the switch. However, my home dhcp server and call manager is 192.168.1.150. I can ping from erotuer to .150 but from interface 0/0.1 10.0.1.1 I can not ping the call manager...
Router#ping
Protocol [ip]:
Target IP address: 192.168.1.150
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.0.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.150, timeout is 2 seconds:
.....
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now