Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1170
  • Last Modified:

ASA 5505 Access List and NAT Questions

I am trying to setup an ASA 5505 with a Mitel phone system. The public IP I am assigning the Mitel Phone system is 50.192.164.234. The internal IP address of the phone system is 192.168.1.10

the following ports need to be forwarded:

For IP phones
67 & 68 UDP
69   TCP & UDP
20001  UDP
5566 TCP
5567 UDP
5004 - 5007 UDP for 86xx tel
6004 - 7039 UDP
50098 - 50508  UDP for 5300 series phones
6800 - 6802 TCP Call Control
3998 & 3999 TCP

Private Networking
5570 TCP
6004 through 7039 UDP

Remote sip and points and gateways
5060 UDP
2427 UDP
6004 through 7039 UDP

Remote Admin open TCP 44000
SSH Server Port - 22
Web Listening Port - 443

69 for UDP



Here is the current config of the firewall. I can't seem to get it working. Not familiar with this version of ASA.



Result of the command: "sh config"

: Saved
: Written by enable_15 at 10:13:48.948 UTC Fri Aug 17 2012
!
ASA Version 8.4(4)
!
hostname ciscoasa
enable password RPv3FkRbkRBiSpEf encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 50.192.164.233 255.255.255.248
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network Mitel
 host 192.168.1.10
object service MitelManage
 service tcp source eq 44000 destination eq 44000
object network 67-68UDP
 host 192.168.1.10
object-group service 2000 udp
 port-object eq 2000
object-group service 22 tcp-udp
 port-object eq 22
object-group service 3998 tcp
 port-object range 3998 3999
object-group service 443 tcp-udp
 port-object eq 443
object-group service 5004 udp
 port-object range 5004 5007
object-group service 50098 udp
 port-object range 50098 50508
object-group service 5566 tcp
 port-object eq 5566
object-group service 5567 udp
 port-object eq 5567
object-group service 6004 udp
 port-object range 6004 7039
object-group service 67-68 udp
 port-object range bootps bootpc
object-group service 6800 tcp
 port-object range 6800 6802
object-group service 69 tcp-udp
 port-object eq 69
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit tcp any host 50.192.164.234 eq 44000
access-list outside_access_in extended permit udp any host 50.192.164.234 object-group 67-68
access-list outside_access_in extended permit 69 any host 50.192.164.234
access-list outside_access_in extended permit udp any host 50.192.164.234 object-group 5567
access-list outside_access_in extended permit tcp any host 50.192.164.234 object-group 5566
access-list outside_access_in extended permit udp any host 50.192.164.234 range 50098 50508
access-list outside_access_in extended permit udp any host 50.192.164.234 range 5004 5007
access-list outside_access_in extended permit udp any host 50.192.164.234 range 6004 7039
access-list outside_access_in extended permit tcp any host 50.192.164.234 range 6800 6802
access-list outside_access_in extended permit tcp any host 50.192.164.234 range 3998 3999
access-list outside_access_in extended permit object-group TCPUDP any host 50.192.164.234 object-group 22
access-list outside_access_in extended permit object-group TCPUDP any host 50.192.164.234 object-group 443
access-list outside_access_in extended permit udp any host 50.192.164.234 object-group 2000
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (outside,inside) source static any any destination static Mitel Mitel service MitelManage MitelManage
!
object network obj_any
 nat (inside,outside) dynamic interface
!
nat (inside,outside) after-auto source dynamic any interface
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 50.192.164.238 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 50.192.164.233 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd dns 75.75.75.75 75.75.76.76
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.254 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:f2710b92df154ebdc6ec335313387245
0
myintellinet
Asked:
myintellinet
1 Solution
 
fgasimzadeCommented:
First, you would need to use inside ip addresses in outside access list

Second: you are missing NAT statements

https://supportforums.cisco.com/docs/DOC-9129 - take a look at the last column
0
 
ArneLoviusCommented:
it might be worthwhile looking at teleworker if you have many remote phones, if you you only have a few, using a VPN might also be an idea
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now