Server keeps defaulting to "Public Network"

Windows Server 2008 R2
Exchange 2010 SP1
VMWare ESXi 5.0

All updates applied

This one server keeps running like a dog after a few days, and after a reboot more often than not (but not EVERY time) it takes 20-30 mins to boot, stuck on Applying Computer Settings.

After it finally finishes booting it had put itself onto Public Network. We have to disable and re-enable the NIC (VMXNET3) in order for it to rediscover the "Domain Network" - and everything springs to life.

I found a few articles about defaulting the NLA location to not Public but there is no option to default to Domain.

Lost for ideas.
bikerhongAsked:
Who is Participating?
 
bikerhongConnect With a Mentor Author Commented:
Hi,

In fact just the other day we finally figured out what was wrong with this - Kaspersky AV - specifically the System Watcher was active even though the Management Policy said it was off!

Got that sorted and this was also sorted, as the problem had appeared on a few Windows 7 PC's as well.
0
 
bikerhongAuthor Commented:
Update:

This time it showed as domain network but (unauthenticated).

No amount of disable/reenable would work.

So I changed it to DHCP, disabled the NIC.

Added a VNXNET2 NIC and configured static IP.

Reboot ok so far.
0
 
Exchange_GeekCommented:
What is the binding order state? Is Public network with higher priority?

Also, w.r.t Server getting stuck at Applying computer setting- blame that purely on Exchange, set Exchange services to have delayed start and you should see the problem go away.

Regards,
Exchange_Geek
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
bikerhongAuthor Commented:
Could you elaborate?

How do I check Binding Order state?

Thanks
0
 
Simon Butler (Sembee)ConsultantCommented:
I have seen this with the VMWARE Adapters before. Changing the Intel adapter resolved the issue for me. Not really an Exchange issue, but for soem reason Exchange seems to be affected a lot.

The long boot up time is symptoms of a failure to connect to the network properly and unable to communicate with the domain controller.

SImon.
0
 
Exchange_GeekCommented:
NIC
Here is a pic that shows how to view and change binding order.

Regards,
Exchange_Geek
0
 
bikerhongAuthor Commented:
Hmm, nothing to be changed in the binding order.

Exchange has been running faster than ever before with VMXNET2 adapter, perhaps for some reason it just didnt like VMXNET3. The reason we went to that in the first place was becuause of network performance issues with the E1000!
0
 
Exchange_GeekCommented:
So, if you remove VMXNET3 - does that help you??

Do you mind running updating VM NIC Driver AND/OR replacing the faulty NIC?

Regards,
Exchange_Geek
0
 
bikerhongAuthor Commented:
See comment
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.